Skip to Content
0

Stopping Submit of a Sales Quote in C4C before triggering for External Follow-up Document Creation

Nov 14, 2016 at 03:59 PM

775

avatar image

Hello all,

We have integrated our C4C Tenant with SAP ERP and creating Sales Quote on C4C. Before triggering the "external follow-up document creation" action from a Sales Quote, we first need to mandatorily "Submit" the Sales Quote, i.e. this triggers an e-mail to the Account e-mail address maintained with a Sales Quote pdf attachment details. Before clicking Submit button the "external follow-up document" button is disabled.

We would like to disable this functionality of having to Submit the Sales Quote each time. Any pointers on how to achieve this would be greatly appreciated.

Regards,

Nikhil

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Dedeepya Reddy
Dec 06, 2016 at 12:33 PM
0

Hi Nikhil,

If you donot want to send Sales Quote for Approval and would require the 'SUBMIT' button to be disabled, you need to modify the configuration for Sales Quote Document Type in Fine Tuning-> Here you must SET 'Direct Customer Acceptance' checkbox and make sure you have not scoped Approval Process for Sales Quote.

With these changes -> Submit button would be disabled, and 'Create External Follow-Up Document' action would be enabled post successful pricing.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Dear @reddy.dedeepya,

In the case we want to perform the below scenario:

1. Request External Pricing for the Sales Quote

2. Submit the Sales Quote for Approval

3. Replicate the Sales Quote to SAP on-Premise system.

What configuration settings need to be done?

As I see in the Business Configuration>Sales Quote> Document Type Fine Tuning Activity, at the time the "Replicate" Check box is 'ticked', the "Direct Customer Acceptance" Check Box is automatically 'Ticked' SO the Submit button is Disabled in the Sales Quote.

Any ideas how to proceed with this scenario?!

Thanks,

Andreas

0
Nikhil Pais Nov 28, 2016 at 08:27 AM
0

Hello folks.

Does anybody have any pointers on this? Please suggest.

Thanks and regards,

Nikhil

Share
10 |10000 characters needed characters left characters exceeded
Jan Westhues Dec 02, 2016 at 09:21 PM
0

Hi Nikhil,

try setting the quote document type as "internal" in fine-tuning. This disables the "Submit" for this type of quote completely.

Don't know if this fulfilling your actual business needs.

BR

Jan

Share
10 |10000 characters needed characters left characters exceeded
Nikhil Pais Feb 17, 2017 at 07:14 AM
0

Thank you folks for your responses. This was of great help to us.

Share
10 |10000 characters needed characters left characters exceeded