Skip to Content
avatar image
Former Member

Leading zeros in the Product allocation characteristic combinations.

Hi All,

I am copying Characteristic combination from planning area to product allocation group, after i complete the transaction system is automatically preceding the zeroes to the product number.

I have one the following activities before copying CVC of planning area to product allocation group.

against all the Product allocation settings.

2.Created the MPOS with product (characteristic length of Product is 18), Customer and Allocation object.

3.Created planning area and planning book.

4.Copied cvc combination from planning are to product allocation group and also copied planning area values in to Product allocation group.

5.Tried to check in the ATP simulation mode, while I was doing system has given no characteristic combination found, when I checked Product is preceding zeros as per the filed MATNR length 40 and this MATNR is selected from the Product allocation field catalog, But when I add zeros to product system is performing Product allocations in simulation mode.

6.Tried triggering gATP Product allocations by creating Order in ECC, here also it has given same error No characteristic combination exists.

When I did initial R&D on this. I found that material number in the product allocation characteristic combination is leading by zeros for ex:- 000000000000000002200325.

Could any one please suggest me what to do on this.

Thanks and Regards,

T.Muthyalappa

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Jun 09, 2009 at 05:39 PM

    Hi Muthyalappa,

    Please check your settings on the following.

    1) Under customisation setting in APO, check under the menu

    spro > sap guide > apo > master data > product > specify output format of a number > under this, check the leading zeros

    2) Under customisation setting in ECC, check under the menu

    spro > sap guide > logistics-general > material master > basic settings > define output format of material umber > under this, check the leading zeros

    The leading zeros are based on these two settings.

    Regards

    R. Senthil Mareeswaran.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      My Proble has resolved based on the Senthil solution, thanks for the interest in trying to help out me.

      Thanks and Regards,

      T.Muthyalappa