Skip to Content
avatar image
Former Member

value help issue in VC

Hi Experts,

I have a requirement that , for a particular field in input form.....i need to have value help with multiple and ranges to be selected.I have done this by using the standard value help wizard.But i also want the users to be able to enter a value manually and get the report output.say for example...if the values for customer number are 100,200,300...etc.....i want the user be able to give 100 as input manually and also i want the users be able to select the value help button for passing the values to customer field.

Also can any one tell me the best way of providing value help for multiple values and ranges selection...other than the standard wizard type...which is not so user friendly...where the user will be poped up with two windows ...one for selecting the type of value help ( Between, Equal, excluding..etc) and other one for selecting the values ( Key , text, keytext table).

Thanks,

P.navakanth

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Jun 06, 2009 at 06:22 AM

    Hi

    You have to create value help for this. Go to that variable & right click for creation of value help.

    Select the BI system & Query for value help. then select the field & select option as values from master data. After creation of value help you will get one push button next to input box for that field. When you click this button one pop up help window will get opened. There you will get all values for this field from master data. Also here are options to select 'Between, less than, etc' you can select from that.

    Make sure your BEs query has variable which accepts multiple values or ranges.

    Refer the following thread also -

    value-help-for-bi-query-field-in-input-form

    regards

    Sandeep

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I want exactly what u have written ...

      I have done same as u have done...but when i enter a single value in the field for which i have a value help...it was not taking the data....how ever let me check tomoro and get back to u.....today our server is down.

      If it is working fine for u...then it should for me also....

      Thanks

      P.Navakanth