Skip to Content

System missing in SAP MMC

I recently upgraded my SOLMAN 7.0 to EHP1 and now it appears that it is missing from the SAP MMC. I tried to add it manually but I kept receiving a DCOM error. Do I need to upgrade the SAP MMC for 7.01?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jun 06, 2009 at 05:39 PM

    Hi

    Can you please verify that your MMC version is the version of your kernel. Can you please try downloading the appropriate one from the marketplace and installing it as this may resolve the issue.

    First of all you should re-add it using the following steps:

    1. Right-mouse click on node "SAP R/3 Systems" and select "Properties" (if this node is not present,

    follow step 1a)

    1a. - Menu option "Console", "Add/Remove Snap-in" - Scroll to "SAP R/3 Manager" and highlight

    - ADD, Next and Finish

    2. Click tab called "Fixed"

    3. In field "Systems" enter the SID, i.e. DEV

    4. In field "Instance", enter host name followed by space followed by Instance number, i.e.eg:

    SAPPRDHOST 00

    5. Click ADD

    If that does not work please try

    1. Stop the SAP service

    2. Open a command prompt

    3. Go to usr\sap\<SID>\exe\run

    4. call 'sapstartsrv.exe -t' from the command line

    5. Confirm the dialog window

    6. Start the service again

    Please look into the following notes:

    373963 Setting up SAP MMC Snap-Ins on non-R/3 NT computers

    82751 Problems with SAP Services & SAP Service Manager

    For it, log as SAPService<SID>; stop the service, close MMC console and from a command prompt, from within the usr\sap\<sid>\sys\exe\run directory, first we execute SAPSTARTSRV.EXE and we first unistall the service by selecting:

    'Uninstall Service + Unregister COM Interface'

    After, we execute SAPSTARTSRV.EXE again for reinstall the service by:

    'Install Service + Register COM Interface + Start Service'

    If this does not help :

    1. Please check whether the files sapmmc.dll and librfc32.dll are placed under the SYSTEM32 directory.

    2. If this does not help, deinstall the service and install it again? Please see the note142100 ( I think you

    have already done this)

    Another cause for the incidence could be that the MMC was closed and saved with "wrong" Setup. Please try the following change:

    Open the MMC and close the whole tree structure until 'SAP R/3 system

    Then close the MMC and answer "Yes" to the question about saving settings.

    The next time you open the MMC, this error message should have disappeared.

    3. Make sure that the environment variables for the <sid>adm and the personal id are the same. Also

    make sure that the path set for these 2 users is exactly identical.

    4. Make sure that you have the correct SAPMMC.DLL. Could you kindly run the command "regsvr32

    sapmmc.dll" in the system32 folder ?

    Hope it helps

    Regards

    Amit

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 08, 2009 at 01:47 PM

    This problem has been fixed. The sapstartsrv.exe in my 7.01 kernel was not worknig. I reverted to an earlier version of that file and the system came up fine.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 13, 2009 at 05:21 AM

    Rename the file SAPEVENTS.DLL to old.

    Replace the SAPEVENTS.DLL file under C:\windows\system32 with new one (from 7.01 kernel).

    and re-register the SAP Services (if needed).

    Edited by: Chandra Sekhar Muppalaneni on Nov 13, 2009 6:21 AM

    Add comment
    10|10000 characters needed characters exceeded