Skip to Content
0
Jun 03, 2009 at 11:42 AM

Help with DC Deployment - Cannot create delegate for component...

15 Views

I inherited a DC several months ago and have been adding functionality to it ever since. I have never had a problem compiling/deploying/executing, etc. until yesterday.

I was adding some functionality that required I add an RFC to the model (which I have done dozens of times before), etc. I had the code all ready, then I deployed and received an error message from the server that starts:

com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: Failed to create delegate for component com.linxas.applications.ofi.OFI. (Hint: Is the corresponding DC deployed correctly? Does the DC contain the component?)

I searched the forum and found several posts that talked about repairing, rebuilding, redeploying, etc. However none of those options has done anything for me. I always end up with that error.

When I do a repair on the dc, an odd thing happens. I loose reference to two variables (one is the ECLIPSE_HOME and the other is the JRE_LIB. I also loose two external jars, the ones for SapMetamodelDictionaryContent.zip and SapMetamodelWebdynproContent.zip. These four entries are missing everytime I do a repair/rebuild. I have to manually put them back.

I have tried deleting the project and reimporting, no change. I tried removing the application through VA before deploying, no change.

I get absolutely no errors in the Task panel, everything seems fine. Just to reiterate I have been working on this DC for months without a single issue. Why would the IDE just start barfing on this like that?

Any help would be greatly appreciated.

FYI, I inherited another DC at the same time and have been doing similar work on it, but have not had this problem (yet?).

Edited by: Tom Cole on Jun 3, 2009 1:44 PM