Skip to Content
avatar image
Former Member

PHP Blank page

Hi,

when i execute http://localhost/monitoring/login.php in browser we get Blank page.

even for http://localhost/monitoring/idstore.php same blank page appears.

However i created sample program(test.php) inside monitoring folder and tested below url

URL : http://localhost/monitoring/

here it works fine.

Any addition setting required in PHP/IIS side.

Please let me know how to fix it.

Thanks

Thirumal.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Jun 01, 2009 at 02:10 AM

    Hello Experts,

    Verifiying the installation of IDentity center monitoring

    After completing installation we verified opening following URL in webbrowser

    http://localhost/monitoring

    But A blank page appears instead of welcome page ..

    SAP solution is given as below
    u30FBVerify the webserver user(Internet Guest Account or network service for MS ISS) has the necessary right for the /template_c u3000folder
    ->>>>  my directory structure \IDM\Monitoring\Template_c
    I created Template_c folder and it has full rights with for Internet guest account.
    
    u30FBVerify Smarty is installed correctly.
    - -->  under folder   \IdM\Monitoring\smarty, we have "libs" directory copied from  Smarty-2.6.18 folder extracted directory.

    But still we get same error.

    should i have to start Smarty engine or set path anywhere.

    any setting required in IIS side?

    regards

    Thirumal.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 01, 2009 at 09:38 AM

    Make sure that the anonymous internet user (IUSR_xxx) has read and write access to php and smarty folders. Also C:\SAP\IdM\Monitoring\templates_c and C:\SAP\IdM\Workflow\web\templates_c folders should have read and write access for this user.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi guys,

      i too have the same problem..anyway to debug this problem?

      I too can execute test.php program under monitoring folder. but Login.php gives blank page.

      Already given full rights for (IUSR_xxx) to all template,template_c,smarty,php,monitoring directories.

      any way to see the log or errors? but i doubt smary engine should work to display this?

      regards

  • avatar image
    Former Member
    Jun 02, 2009 at 06:46 AM

    Check your config.xml files and make sure they are correct. Also check your php installation. did you install correctly?

    Do you have another instance running? Can you compare the php.ini files?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      HI mathew,

      thanks for your reply

      I checked the Config xml file under /monitoring folder, what do you want me to check here?

      <?php xml version = "1.0"?> 
      - <MAXWARE>
      - <MONITORING>
      - <IC>
        <name>Identity Cen</name> 
        <servertype>MSSQL</servertype> 
        <serveraddress>sap-idm</serveraddress> 
        <databasename>MXMC_db</databasename> 
        <databaseuser>MXMC_user</databaseuser> 
        </IC>
        </MONITORING>
        </MAXWARE>

      I think PHP is installed correctly thats why test program(Text.php) program created under monitoring folder is working fine.

      Do you have another instance running? Can you compare the php.ini files?

      ....>>Can you pls elaborate more on this...

  • avatar image
    Former Member
    Jun 02, 2009 at 05:51 PM

    Check these parameters and make sure they are correct. Is it the correct database? Server, etc?

    Can you log into your database with MXMC_User and the appropriate password?

    If all else fails try reinstalling monitoring.

    My other question was wondering if you had any other instances of IDM running. You could compare the configurations.

    Matt

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member
      Check these parameters and make sure they are correct. Is it the correct database? Server, etc?
      Can you log into your database with MXMC_User and the appropriate password?

      I checked the parameters, its looks fine.

      During the monitoring installation we gave corresponding entries. those entries are

      replicated in config file.

      Also I tried login to Database mxmc_db using mxmc_user/pwd in SQLServer. Its loging fine.

      However one of the problem i face still now is

      URL link Http://localhost/monitoring is not working, giving me blank page.

      Already full rights given for IUSR_,,, to access /monitoring and /template_c, /template,/smarty folder and Php folders too

      Since one of my test program working under /monitoring i believe php is working fine.

      pls suggest me anything is left.....

      If all else fails try reinstalling monitoring.
      My other question was wondering if you had any other instances of IDM running. You could compare the configurations.

      -->> i dont have IDM running already.

      can you give me some more ideas to debug the problem.

      regards

  • avatar image
    Former Member
    Jun 03, 2009 at 10:51 AM

    I would suggest

    shutting down all dispatcher and event services (if enabled)

    unisntalling monitoring

    reinstalling monitoring.

    Not sure of what else you can do.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 08, 2009 at 06:53 AM

    Also do double check php.ini, make sure the session and download folders exist and have read/write permissions.

    I had some similar problems here:

    http://idm-thoughtplace.blogspot.com/2009/04/web-ui-password-troubleshooting.html

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 29, 2010 at 05:45 AM

    Thanks

    Add comment
    10|10000 characters needed characters exceeded