Skip to Content
avatar image
Former Member

Change price control from 'V' to 'S'

Gurus,

I need to change the price control indicator for a material from 'V' to 'S' to allow cost rollup for this finished part. However I am not able to do so as the field is greyed out in the material master.

Some points that I checked -

1. There are open Prod orders against this item, but none are confirmed

2. There are no movements - i.e. GR/GI etc against the material

3. In OMW1, price control 'S' is maintained against the material type and there is no tick in 'price control mandatory' checkbox

4. The field is not lock relevant.

5. In other plants the price control is already maintained as 'S'.

Am I missing something?

I have gone through lots of threads on this forum, but could not find an answer. Most answers point to standard SAP help documentation. But the problem in this case is that the field is greyed out and does not open up for editing , no matter what I do.

Please help.

regards,

SB

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    May 25, 2009 at 01:13 PM

    hi,

    you cange it in MM02. I tested now , sytem allowing to change.

    Prices of all materials will be recaliculted when you change V to S or S to V.

    If it is not allowing for your case check the field selection settigs for material master.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 25, 2009 at 01:17 PM

    Please try this with T.Code. MM17 (MBEW-VPRSV).

    If it will not process,then check what error massage its giving.

    Edited by: Prashant Prasad on May 25, 2009 3:17 PM

    Add comment
    10|10000 characters needed characters exceeded

  • May 25, 2009 at 02:35 PM

    Hi

    Check whether split valuation is active for the material (valuation group code in accounting view is there?). For split valuated materials you cannot maintain price control as S.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

    • have you tried it in MM02? Is the field grey or open to a change?

      I guess your material type is customized to not allow a change.

      Hence you have to change the material tpye attributes customizing to be able to cahnge the price control.

  • avatar image
    Former Member
    May 26, 2009 at 04:52 AM

    Hi,

    Please, check your Material master Field Selection Control for the field " MBEW-VPRSV ".

    Check Tcode OMSR & OMS9 or

    Go to SPRO -LOgistics General Material Master -Field selection --

    hope it helps

    Regards,

    Rahul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 05, 2009 at 09:32 AM

    Hello,

    I had the same problem, no proposed suggestion helped. Please try the following:

    SPRO: Logistic-General>Material Master>Basic settings>Material types>Define attributes of material types

    Go to needed material type and display settings. Check if tab "price Cntrl mandatory" is active.

    If it is - remove the tab.

    Price Control Mandatory

    Use

    Determines whether the price control indicator defined for the material type appears as a default value (indicator not set) or a fixed value (indicator set) when material master records are created or changed.

    Kind regards

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 22, 2013 at 08:57 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded