Skip to Content
avatar image
Former Member

Smart form printing issue with LOCL and SAP printer

Hi,

The issues are as follows:

1. the top portion of the Invoice and PO does not print when using the SAP printer (works when using LOCL)

2. the shaded areas of the Order Confirmation and Invoice are black when printing to a SAP printer (works when using LOCL)

In an attempt to correct the printing issue is was suggested that we change the SAP printer device type from HPLJ4 to POST2. This did address the problem where the shaded areas were black but then we received reports that other reports printed "garbage". Its possible that using POST2 device type causes issues when printing to HP compatible printers.

Apparently all the testing was done using the SAP printer LOCL and not the SAP printer name and SAP spool system. LOCL uses the SAP GUI and Windows system to produce the output. Our production users at the plant site and Toledo are using SAP defined printers with the device type of HPLJ4. HPLJ4 is our standard here as OC for our printer definitions and we have HP compatible printers installed in our Toledo location and all of our remote sites. We need to be able to correctly print the Invoices, Purchase Orders, Sales Order Confirmations on our SAP printers.

What can be done to the reports to allow them to print on our HPLJ4?

Thanks, Prathap

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    May 25, 2009 at 06:04 PM

    Hello Prathap,

    LOCL is for printing A4 size printout.

    Just check the same for HPLJ4 and other it must be different.

    I have also faced similar kind of problem in one of my last projects.

    The Black shade comes only when the format used in smartform is different from printer format.

    You can even ask you BASIS team to assign default printer as LOCL for all user in there server.

    Or this can be done by

    tcode SU3-> Default tab -> printer as LOCL.-> save.

    Hope this solves your issue.

    Regards,

    Suvendu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 25, 2009 at 12:50 PM

    Please help me. This is a critical issue.

    Thanks, Prathap

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 25, 2009 at 05:41 PM

    Hi Prathap,

    Check the background shading of the windows of the Smartform where you get the black boxes. If it is set something like this:

    Color: White

    Saturation: 100%

    this can be the problem.

    I know it is strange but some black and white printers cannot handle this setting. They only know one color black so the ignore the color setting and just take the saturation 100% setting.

    The reason it works with local and device type SAPWIN is that the print data is created in Windows and sent to the printer as graphic.

    Please change the shading for window MAIN -> tab 'Output Options' to:

    Color: Black

    Saturation: 0%

    and this should resolve the problem.

    Then create a new spool and check if the problem is resolved. See SAP Note #400050.

    Regards,

    Aidan

    Add comment
    10|10000 characters needed characters exceeded