Skip to Content
author's profile photo Former Member
Former Member

How to adjust the data package size?

If anyone can let us know how to adjust the data package size for data loading, we will be very appreciated!

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 28, 2009 at 12:37 PM

    Hi Kevin

    Open the infopack then goto scheduler from menu then select DataS. Default data transfer.

    Then enter the data package size.

    Hope it helps..

    Chandu.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 28, 2009 at 09:57 AM

    Hi Kevin,

    The data extraction parameters can be set in two ways:

    - one directly on the source system with table ROIDOCPRMS

    - or within the BW system itself through SBIW -> Maintain Control Parameters for Data Transfer

    Some extra info on source sys tbl ROIDOCPRMS:

    It contains the control parameters for data transfer from the source system to BW:

    maxsize - maximum size of an IDoc packet in KB;

    statfrqu - the number of packets that are transferred before statistical info is sent

    maxlines - maximum number of records sent in one IDoc packet;

    maxprocs - maximum number of dialog work processes per upload request used to send the data to the BW system

    If table ROIDOCPRMS is empty, the systems use default values during runtime.

    You should not allow these default values to be used.

    See also

    Note 417307 Extractor package size: Collective note for applications

    Rgds,

    Colum

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 24, 2009 at 02:40 PM

    HI,

    While loading data use selection condition based on date/key field, so that package size will be less.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 24, 2009 at 03:09 PM

    Hi,

    Open your InfoPackage.. In the Menu you will find the option, package size.. You can change it from there...

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Well Kevin...in general the infopackage size is a calculated value....the process is in SAP BI (somewhere in SPRO customizing.... i dont remember) theres a system parameter that have the memory space assigned to an infopackage by example 20000 KB the system calculates the number of records than the nfopackage can bring in 2000KB; depending of the size of the record (a record with many fields needs more space than another one with few fields), if you want to bring more records you must change the memory size......

      But this is a general configuration...theres a way to set up a specifical configuration for every datasource, in Infopackage menu> sheduler>DataS. Default data Transfer..... here you can change the packet size in KBytes and the number of records per idoc....

      I hope this helps you..

      Regards

  • Posted on May 27, 2009 at 09:05 PM

    hi,

    You can also maintain entry in table ROIDOCPRMS on R/3 side for your source system to adjust data package size. Please refer to the sap note 401847 for more details on this. Other thing you can do is at Infopackage level, you can maintain the datapackage size.

    Hope this helps.

    Amol

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 03, 2014 at 09:21 AM

    This message was moderated.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.