Skip to Content
avatar image
Former Member

wd and adaptive web service

Hi, we are facing a nasty effect when using the web service model as template for the context of view.

As known nodes with cardinality 0..n will result in disabled inputFields but I cannot change the cardinality of the nodes on all levels to 1..1. the lowest nodes have been changed to 1..1 but higher ones are not changeable.

As a workaround we have tried to build a second tree of attributes for the UI fields and map them to the structure fields of web service nodes.

Is there a better way to achieve this?

regards

M.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    May 22, 2009 at 12:17 PM

    Hi , Michael

    you need to make chaneges in the model context node of the component controller .

    once u maed changes in the component controller then the effects will be reflected in the view context.

    Regards

    Anoop

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 23, 2009 at 01:31 PM

    HI

    i guess you may have binded the model attributes to the input field

    , instead chaging the cardinality or create a instance for the model class of the model node in the init() method ,

    you can use the value node bind it to the input field ,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hi Michael.

      If the cardinality of the Node is 0..n or 0..1, you need to create and add element in this node before you use in the view. The fields are disable because there are no elements in the node. When you put 1..1 cardinality or 1..n , already have at least one element in the node, because this works finely.

      Try to create and add some elements in node in your component controller. Probably it will works fine.

      Regards

      Marcos