Skip to Content
author's profile photo Former Member
Former Member

Setting the Graphic Location to https address

I want to provide the user the option to set the location (http or https) of the logo file.

It works fine when the graphic location of Picture was set to http:// address whereas it is https:// it doesn't display the image.

When I use IE to load the image both http and https location works fine.

Is this is known issue or is there any way I can debug to find out what's causing this issue.

Thanks for your response.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 22, 2009 at 02:44 AM

    Hi,

    If you have the same issue mentioned in note #1281124 below is the description:

    Note can be searched from here:

    [https://www.sdn.sap.com/irj/boc/notes]

    Symptom

    Crystal Reports .NET SDK application.

    Production system with CR .NET SDK (version 12) installed.

    Change graphic location of a picture object to http source.

    The picture object doesn't change if a HTTP source is used.

    The picture object changes correctly if local file is used on a mapped drive.

    Reproducing the Issue

    Crystal Reports 2008 SP1

    Visual Studio .NET 2003, 2005, or 2008

    Add a Picture object to a Crystal Report

    Right click the picture object on the report and select Format Graphic

    Click on the Picture tab

    Click on the X-2 button beside Graphic Location

    Enter the URL of your graphic. For example "http://www.sap.com/canada/company/press/images/Raihan_Riaz.jpg"

    Use this report in a CR .NET SDK app on a computer with the CR .NET SDK installed

    Note The CR .NET SDK must be installed using Crystal Reports 2008 Redist Install, ClickOnce, or a setup package including the Crystal Reports 2008 merge modules.

    Cause

    This is a known issue and tracked with ADAPT01172734

    This problem occurs because libcurl.dll is missing on the production system.

    The Crystal Reports 12 Server Install, merge modules, and ClickOnce don't install libcurl.dll.

    Resolution

    This issue has been resolved

    Use the redistributable package or merge modules from Fix Pack 1.4 to distribute the Crystal Reports 2008 runtime files

    The redistributable files for Fix Pack 1.4 can be downloaded here SAP Crystal Solutions Downloads

    Regards,

    Shweta

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      It is different issue. I have libcurl.dll file on the server. I have mentioned the picture changes if I specified the graphic location with http:
      whereas if I changed it to a https:
      location it fails to update the picture.

      You can reproduce my issue by simply changing the graphic location to https address.

      Thanks

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.