Skip to Content
avatar image
Former Member

Calling a portal page in using Webdynpro

Hi Portalites,

I have developed an webdynpro iview, where it will call other uwl page inside the code.

This iview is placed in home role(like welcome page).

in wddoinit method, i have written the code,

where portal users locale is set to English.and then it will navigate to UWL using WDPortalNavigation method.

WDPortalNavigation.navigateAbsolute("ROLES://uwl_page",

WDPortalNavigationMode.SHOW_INPLACE,

(String)null,

(String)null, WDPortalNavigationHistoryMode.NO_DUPLICATIONS,

"UWL",

(String)null,

(String)null);

Iam able to view the UWL in Home page, but after that if i click on any user admin, or content admin roles, and agian clicking on home page again or refreshing the page it is showing previous navigation path in top level navigation but in content area it is dispaying uwl.

Let us clearly expalain, first i have opened portal, home page opened with UWL page in content area.after that i clicked on sytem admin > sytem configuration, after that when i cliked on home role again in TLN, in the TLN it is highlighting system admin >system config but displaying UWL in content area.

In the detailed navigation, it showing all iviews what home page has.

Please advice.

Thanks

Sony.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • May 14, 2009 at 03:20 PM

    Hi Sony,

    It may be caching problem.

    So close all your portal browsers and delete your cache and temporary files.

    OR It may be because you have been aaded to lots of Portal roles and groups.

    So try minimizing your role and group assignment on portal.

    Hope this helps. Am not sure though. Just give it a try.

    Regards,

    Biroj Patro

    Add comment
    10|10000 characters needed characters exceeded