Skip to Content

0PM_DS04 not add records from 0PM_OM_OPA_2 in BW Prod.

Hi

DSO 0PM_DS04 stored data from following 4 different DataSources and stored correctly in Dev and QAS environment:

1) 2LIS_17_I3OPER
2) 2LIS_17_I3HDR
3) 0PM_OM_OPA_1
4) 0PM_OM_OPA_2

But first 3 DataSources, records are transferred and added correctly in production but DS 0PM_OM_OPA_2 's records are only transferred but not added in Prod.

How to resolve this issue?

ISKhan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Sep 10, 2018 at 06:35 AM

    I raised an OSS, actually there is an issue in standard start routines and SAP find it rectify it so now issued resolved.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 12, 2018 at 08:11 PM

    Hi Iskhan,

    There are plenty of documentation available in LaunchPad about 0PM_OM_OPA_*. To provide you a proper selection of the available documentation it would be necessary to know your SAP_APPL component version (from ECC).

    I am considering you have this issue in full loads, then try to run RSA3 in your Source System for the same DataSource. If you still get no records , you may try append the value of WRTTP to parameter WRTTP_LIST in table BWOM_SETTINGS. If there're several values for WRTTP, you can use comas as separator.

    Check an example:

    ID_OLTPSOURCE: '0PM_OM_OPA_2'

    ID_PARAM_NAME: 'WRTTP_LIST'

    ID_PARAM_VALUE: "04,17,42"

    WRTTP - its value can be acquired from view COVP.

    Before doing that, I recommend read this note: 2302518 - BW-BCT: "Value type selection for PM extractors", and also consider that the additional selection of code values may increase the runtime of the extraction significantly. In PRD environments the amount of data is usually very different from QAS/DEV so the performance aspects must be consider. In this case I recommend in advance to have in hand Note 1775336 - BW-BCT: Performance during COSP/COSS extraction.

    Cheers!

    Tania

    Add comment
    10|10000 characters needed characters exceeded

    • First the obvious.... are you using any customer exit?? Which method for loading are you using?

      When you say "is transfered but not added", you mean you can see the records in the DSO for the 1st two only. Do you have PSA? if yes, check there if the records are there. If they are not even going to BW, I advise to check the background job (SM37) of it to see if there are hints.. do they appear in RSA3? It is very strange indeed... a lot of questions arise.

      Hoowever... if you main concern is to have it working, reinitialize it from BW side (selective deletion, full repair..) and see if it works.

      Feel free to ask further :)

      Cheers!