Skip to Content
0
Former Member
May 10, 2009 at 04:03 AM

Missing columns(with data) on deployment machines.

33 Views

I am having a weird issue..

Windows application built with vb.net 2005

Crystal reports.net

I have a report with a sub report. Some of the columns in sub report are missing on customers machines. On the developer machine all are fine.

Debug info so far.

1. Tried the same report on customer machine and on the developer machine(missing columns on customer)

2. Tried customeru2019s database here on development machine (all columns displayed)

3. Tried on another computer at customer location (missing columns). Even tried new sql server install and database copied.

4. Tried on brand new os at the developer location (all columns displayed). Here we used the developers sql server

I am totally confused why this is happening. I am not new to crystal reports been working on CR since 2000. I can not think of anything. If used no sub reports everything is fine!

For report run time deployment i am using CRRedist2005_x86.msi rev number {38ECA77D-543C-4875-9D8A-9F21350DA05C}

Has anyone experienced this?