Skip to Content

XSODATA ERROR 405 (Method Not Allowed)

Hello,

I am facing an issue with my xsodata. Everything works fine

Nevertheless, I get the error: HEAD 405 (Method Not Allowed)

I have the following issue :

Especially I don't understand why it says that the allowed headers are GET, POST, PUT, PATCH, DEL - while my settings in the XS Admin Tool are different.

Here is my .xsaccess file

{
    "exposed": true,
    "authentication": {
        "method": "Form"
    },
    "cache_control": "must-revalidate",
    "cors":
    {
        "enabled": true,
        "allowMethods": ["GET", "POST", "HEAD", "OPTIONS"],
        "allowOrigin": ["<My domain>"],
        "allowCredential": true,
        "exposeHeaders": "access-control-allow-headers,access-control-allow-origin,access-control-expose-headers,authorization",
        "allowHeaders": "Origin, Content-Type, Depth, User-Agent, X-File-Size, X-Requested-With, If-Modified-Since, X-File-Name, Cache-Control",
        "maxAge": "3600"
    },
    "enable_etags": false,
    "force_ssl": false,
    "xhrFields": {
        "withCredentials": true
    }
}

Could you help me ?


Thank you

Max

Add comment
10|10000 characters needed characters exceeded

  • I do not think this (HEAD) method works in xsodata... however, you should be ok to use GET .. which is almost the same.

    do you need to use HEAD specifically? for what purpose?

  • Get RSS Feed

1 Answer

  • Best Answer
    Aug 18, 2018 at 07:57 PM

    Hello,

    I have solved my issue. (2524052 - How to disable HTTP HEAD requests)

    It was not working inside the controller.

    I have put it directly inside my manifest.json :

        "models": 
    { "timesheet" :
    { "dataSource" : "timesheet", "settings":
    { "disableHeadRequestForToken": true <===== } } }

    Add comment
    10|10000 characters needed characters exceeded