Skip to Content
avatar image
Former Member

XSA client tools login error. UAA at http://vhcalhdbdb:30032/uaa-security is not up.

Hello,

I am trying to login to SAP XSA Admin using XSA client tools.

API_URL: http://xxx.xxx.xxx.xxx:30030 
USERNAME> XSA_ADMIN 
PASSWORD> Authenticating...
Authentication failed. UAA at http://vhcalhdbdb:30032/uaa-security is not up.

I am unable to login to the XSA admin and also unable to access SAP Web IDE for SAP HANA. I have successfully completed setting the Microsoft Azure instance for hosting HANA Developer Edition. Only problem is I am unable to login through XSA Client tools and Web IDE.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Nov 13, 2016 at 01:17 PM

    Are you trying to connect via IP address? This won't work because of the redirect to the UAA hostname. You must setup a hostname alias to vhcalhdbdb.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I tried setting up the host name to vcalhdbdb but that didn't work. I also checked in the HANA studio and UAA service is running. It is naked in green color but the CPU processes and memory allocation bars

  • Nov 14, 2016 at 12:09 PM

    >I tried setting up the host name to vcalhdbdb but that didn't work.

    What about it didn't work? Did the hostname not resolve to the UAA service still or did the hostname not resolve at all?

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 17, 2016 at 10:01 AM

    I have the same problem. I set up the system via Amazon Web Services.
    I am able to access the XSC but not the XSA.
    I tried using the different users stated on http://host:8000/sap/devs/edition/index.html.

    XSA_ADMIN on the prompt gives:

    xs login -a http://vhcalhdbdb:30030 --skip-ssl-validation 
    API_URL: http://vhcalhdbdb:30030 
    USERNAME> XSA_ADMIN 
    PASSWORD>
    Authenticating...
    Authentication failed. UAA at http://vhcalhdbdb:30032/uaa-security is not up.

    Also I am not sure if I have to use the password on XSA_ADMIN which I stated in the cloud library while setting up the system.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 01, 2016 at 03:48 AM

    Hello Experts,

    I have downloaded and completed setting up HANA express edition using VM Image, now I see error same as above when logging in using

    xs login -u xsa_admin -p <pwd>

    get the below error

    Authenticating...
    Authentication failed. UAA at http://hxehost:30032/uaa-security is not set up.
    
    

    Appreciate the solution here

    ,

    Hello Experts,

    I have downloaded and completed setting up HANA express edition using VM Image, now I see error same as above when logging in using

    xs login -u xsa_admin -p <pwd>

    get the below error

    Authenticating...
    Authentication failed. UAA at http://hxehost:30032/uaa-security is not set up.
    
    

    Appreciate the solution here

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 01, 2017 at 06:25 PM
    Add comment
    10|10000 characters needed characters exceeded

    • I don't think any of that applies to the current image in CAL, it's been over a year and a lot of revisions of HXE. I would suggest creating a new question and providing details of what you are trying to do and what is failing.