Skip to Content
avatar image
Former Member

Post button not appearing for tcode FV60 in ECC6

Hello SAP Experts,

In 46C tcode FBL1N was used to identify open vendor line items. If a parked document is selected, it is displayed via FV60 (tcode FBL1N > FV60). Changes can be made to the parked document and then the parked document can be posted using the "Post" button.

The "Post" button is no longer available here in ECC6. However the "Post" button is available is tcode FV60 is called directly.

I have done some research on the SAP Support Portal and found that SAP note 988188 (FIPP/ENJOY: Release relevance for parked documents) is applied as of release 600.

Will commenting out the changes made in this note activate the "Post" button again for the above scenario and will this only affect FI-AP transactions?

Regards,

Peter

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

9 Answers

  • Best Answer
    avatar image
    Former Member
    May 04, 2009 at 09:44 AM

    Hi ,

    To slove this error reset or slect the screen variant at FV60.

    For that go through this path>EDIT>SCREEN VARIANT>RESET SCREEN VARIANT OR SELECT VARIANT AS SAPFIN.

    Regards

    Surya

    Add comment
    10|10000 characters needed characters exceeded

  • May 05, 2009 at 10:39 AM

    Hi,

    Go to t-code SHDO.

    Select Standard Variant tab

    Give the t-code

    Give an F4 on the variant and check if anything exist.

    If you really do not want the variant, Click the 'inactivate' icon in the same tab.

    Regards,

    Sridevi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 05, 2009 at 12:05 PM

    Hi,

    What you said is right.. You are not following the right procedure..

    Please follow the following steps..

    - Goto FBL1N, Give your selection criterion and select the parked document.

    - Double click on the parked document.

    - Goto Document in the top menu bar, click on change

    - The document is in change mode now..

    - Make relevant changes and you can as well see the post button...

    Hope you got it..

    Chill Madi

    Raghu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I am able to post without any extra config settings..

      Thats coming as a part of standard and it should, in fact..

      Raghu

  • avatar image
    Former Member
    May 08, 2009 at 05:23 AM

    Hi Peter,

    Try the following:

    Create a fresh new role and assign FV60 and fb60 tcode

    Assign that role to user

    Remove all other role and run the tcode fv60

    Regards,

    Kiran

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello SAP Experts,

      Is anyone else on release 600 with support pack SAPKH60013 applied?

      Could you please try the following:

      Access tcode FBL1N

      Specify company code and vendor/s

      Select "Parked items" for document type

      Execute

      Double click on a parked document

      Then goto Document > Change

      "Post" button will not be displayed here.

      Post option is also greyed out from the menu - Document > Post.

      Note that the parked document is complete and it has been released.

      Any idea's why the "Post" button isn't availabe?

      As far as I can tell it's not due to configuration or security. Refer above post for items that have already been checked/verified.

      Regards,

      Peter

  • avatar image
    Former Member
    May 05, 2009 at 10:33 AM

    Hello Surya,

    Thanks for your reply.

    I have reset the screen variant from EDIT>SCREEN VARIANT>RESET SCREEN and this did not correct the issue. "Post" button is not appearing.

    Selection variant "SAPFIN" also is not available in the list.

    Again, the "Post" button does appear when tcode FV60 is called directly. However, when tcode FV60 is called via FBL1N, the "Post" button is not displayed here.

    We are are currently have patch level13 applied for release 600.

    Regards,

    Peter

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Sridevi,

      I have checked in tcode SHD0 and verified that no screen variants exist for tcodes FV60 or FBL1N.

      So there is nothing to deactivate.

      Tcode FV60 is fine when called directly - the "Post" button is displayed.

      The issue is when tcode FV60 is called via FBL1N (Vendor Line Item Display) and the "Post" button is not displayed. Thus parked documents cannot be posted from here.

      Regards,

      Peter

  • avatar image
    Former Member
    May 05, 2009 at 02:17 PM

    Dear SAP_MUPPET,

    You are right when thinking of implementing sap note 988188, but should previously implement note "979967- FIPP/ENJOY: Posting deactivated for parked document" as it is an update of that one.

    Afterwards, you should also implement

    1276062 - ENJOY: Selection of parked documents not from FBV2

    1020057 - FIPP/ENJOY: Posting deactivated for parked document

    I hope this information helps. Regards,

    LiFeRo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello LiFeRo,

      I have applied SAP notes 979967 & 1276062 and the post button is still not appearing when accessing the parked documents in change mode via tcode FLBN1 > FV60.

      Maybe SAP note 988188 needs to be commented out to activate the "Post" button?

      Include MF05AFSENJ

      Line 783

      IF g_enjoy_from_fbv2 = char_x "Note988188

      and g_enjoy_from_fbv0 = space. "Note988188

      exctab-okcod = 'BU'. "Note988188

      collect exctab. "Note988188

      ENDIF. "Note988188

      Any other config items that I can check here?

      I have verified that no standard screen variants exist in tcode SHD0 for FV60 and FBL1N.

      Regards,

      Peter

  • avatar image
    Former Member
    May 07, 2009 at 09:24 AM

    Hello SAP Experts,

    Can you please review this tread again. Any input would be much appreciated.

    Summary of the issue:

    In 46C tcode FBL1N was used to identify open vendor line items. If a parked document is selected, it is displayed via FV60 (tcode FBL1N > FV60 > Document > Change). Changes are made to the parked document and then the parked document can be posted using the "Post" button.

    We have upgraded to ECC6 and the "Post" button is no longer appearing for this scenario when tcode FV60 is called indirectly. However the "Post" button is available if tcode FV60 is called directly.

    The following configuration items and SAP notes have been checked:

    No screen variants have been set in SHD0 for tcodes FBL1N or FV60.

    The following SAP notes have alled been installed or have now been applied:

    979967 (FIPP/ENJOY: Posting deactivated for parked document)

    988188 (FIPP/ENJOY: Release relevance for parked documents)

    1020057 (FIPP/ENJOY: Posting deactivated for parked document)

    1026422 (Initialization error in parking workflows)

    1276062 (ENJOY: Selection of parked documents not from FBV2)

    Regards,

    Peter

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 07, 2009 at 09:45 AM

    Hi Peter,

    In Fv60, the post button will appear if the user has been given a role which comtains any post ing tcode eg F-02/ Fb50 etc.

    Check the following at your end :

    Create a role and assign only FV60. assign the role to user or user to role and now you will see that the user dont have post button option in FV60

    Create other role and assign both FV60 and F-02 , then you will see that the user has the post button activate in FV60.

    Regards,

    Kiran

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Kiran for your response here.

      I have verified that the role has both F-02 and FV60 assigned.

      "Post" button is still not appearing here.

      Also activity type 10 "Post" has also been added to the role but did not resolved the issue.

      Again, here is an overview of the problem:

      Accessing tcode FV60 directly-

      Tcode FV60

      "Post" button is displayed

      Accessing tcode FV60 indirectly-

      Tcode FBL1N > FV60

      Document > Change

      "Post" button is not displayed

      Regards,

      Peter

  • Apr 21, 2010 at 02:48 PM

    Hi,

    According to SAP, the situation which you

    describe is current SAP standard behaviour! The reason behind this

    change of functionality is the following: if you choose from the

    FBL1N list 'document->modify' for a parked document, you switch into

    change mode analogeously txn. FBV2. Within FBV2 you can only change

    a parked document, but you can't post it. The same logic applies now

    to ENJOY parked documents (FB60/FV60). Therefore you have to post

    such documents either via FV60 directly (with FBL1N list in a 2nd mode

    befor your eyes) or via FBV0.

    Hope it clarifies but certainly not help

    Add comment
    10|10000 characters needed characters exceeded