Skip to Content
avatar image
Former Member

No replication of data

Hello,

I've configured the whole scenario of replication using MaxDB 7.6, until the point where the Master/Client Unit were activated successfully, the destinations were successfully synchronized on Message Server, etc. When I execute "Send content to client" the following message appears:

Initial Content Distribution 'Client' ...

Initial Content Distribution 'Client': 5 messages sent

So it seems to be no problem on the replication, but when I check the client tables, there are no data at all.

PS: The replication_* tables were created at the client DB and filled with data, such as the UNIT_ID on the replication_units table.

What could be the problem?

Regards,

MY

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Apr 30, 2009 at 08:26 AM

    Hello,

    I will draw a very rough picture of the SyncMan infrastructure.

    MasterDatabase <-> SyncService <-> MessageServer <-> SyncService <-> ClientDataBase1.

    |

    <-> SyncService <-> ClientDataBase2.

    What you describe is the inital transport of the master data to the MessageServer.

    Now you have to start the SyncServices for the ClientDataBases to receive the data that resides on the MessageServer and of course the SyncService for the MasterDatabase to track changes.

    Please keep in mind that the SynchronizationManager was not designed to transprot mass data but to keep in sync two databases.

    Best Regards

    Wolfgang

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Wolfgang,

      You are right! The "Send content to client" was only the initial transport of master data to the Message Server. Once SyncService is activated, the client tables were filled.

      Thanks!