Skip to Content
0
Former Member
Apr 24, 2009 at 11:51 AM

Items not appearing in cascading dynamic list

25 Views

Hi

I am having an issue with cascading prompts in Crystal Reports 2008. I have two cascade levels in this report. The report worked fine for a few months until we recently noticed some items were not showing up on the first list. In the database, there are 186 values but only the first 162 are showing up in the selection list. The maximum value for the list is 200 (this has been confirmed by running another report with more than 200 items -- the list is displayed in 2 batches).

Crystal reports IS able to retrieve all the items for certain functions. For example, when I browse data in the field explorer, all the items appear. Also, when I run the select expert.. record.. and choose the "{field name} is equal to" option from the drop-down list, all items are displayed in the list of options on the right-hand side.

If I re-enter the prompts without the second level cascade (no cascading) then all the items appear in the list.

I created a new report from a blank report that contains only the 2 tables necessary to repeat the error (linked the same way as in the original report). The exact same behavior was observed for the newly created report.

Also, I have created two .csv files with the data from the two tables and a new .rpt file that uses the .csv files. I was going to attach them so you can see the behavior, but I cannot see how to do this. Is it possible to attach files to messages on this forum?