Skip to Content

Data Services Crashes at logon: C0000005 ACCESS_VIOLATION

Hi Everyone!

My Data Services Designer 4.2 SP9 is suddenly closing after logon.
User and password are informed and repository selected, then the application loads about a minute and closes without any error screen.
That happens with any user on my laptop. In others machines, my user works fine.

I'm using Data Services 4.2 SP9 in Windows 10 OS.

I also tried to complete reinstall DS software, cleaned AppData folder, changed the Job Server's service user, change permissions on Installation folder and reviewed the Windows Firewall options. None of those worked.

The log file shows the folowing:

(14.2.9) 07-31-18 12:33:45 (R) (4728:12524) SYS-170101: System Exception <ACCESS_VIOLATION> occurred. Process dump option is off. Process is not dumped.
                                                                                                     Call stack:
                                                                                                     0x00000000803DCA9D, CBCGPToolBar::UpdateTooltips()+0173 byte(s)
                                                                                                     0x00000000803D0082, CBCGPToolBar::AdjustLocations()+1602 byte(s)
                                                                                                     0x00000000803D82A6, CBCGPToolBar::OnSize()+0102 byte(s)
                                                                                                     0x000000008003FC92, CBCGPBaseControlBar::WindowProc()+0338 byte(s)
                                                                                                     0x000000001EE56CC1, CallWindowProcW()+1217 byte(s)
                                                                                                     0x000000001EE562CE, SendMessageW()+0878 byte(s)
                                                                                                     0x000000001EE5474C, GetWindowTextW()+2236 byte(s)
                                                                                                     0x000000001EE53E52, UpdateWindow()+0242 byte(s)
                                                                                                     0x000000001B274704, HitTestThemeBackground()+23796 byte(s)
                                                                                                     0x000000001B2734E1, HitTestThemeBackground()+19153 byte(s)
                                                                                                     0x000000001EE54394, GetWindowTextW()+1284 byte(s)
                                                                                                     0x000000001EE56CC1, CallWindowProcW()+1217 byte(s)
                                                                                                     0x000000001EE5688B, CallWindowProcW()+0139 byte(s)
                                                                                                     0x00000000803D8F30, CBCGPToolBar::OnWindowPosChanged()+0080 byte(s)
                                                                                                     0x000000008003FC92, CBCGPBaseControlBar::WindowProc()+0338 byte(s)
                                                                                                     0x000000001EE56CC1, CallWindowProcW()+1217 byte(s)
                                                                                                     0x000000001EE5699C, CallWindowProcW()+0412 byte(s)
                                                                                                     0x000000001EE64C10, IsThreadMessageQueueAttached()+0160 byte(s)
                                                                                                     0x0000000020CBDBC4, KiUserCallbackDispatcher()+0036 byte(s)
                                                                                                     0x000000001DE41504, NtUserSetWindowPos()+0020 byte(s)
                                                                                                     0x000000008003F752, CBCGPBaseControlBar::SetWindowPos()+0066 byte(s)
                                                                                                     0x00000000803D0376, CBCGPToolBar::AdjustSize()+0678 byte(s)
                                                                                                     0x00000000803CF9E5, CBCGPToolBar::AdjustLayout()+0565 byte(s)
                                                                                                     0x00000000803D448F, CBCGPToolBar::LoadState()+0591 byte(s)
                                                                                                     0x00000000804B7939, CBCGPWorkspace::LoadState()+0697 byte(s)
                                                                                                     0x000000008018F5BD, CBCGPFrameImpl::OnLoadFrame()+0045 byte(s)
                                                                                                     0x000000008024385B, CBCGPMDIFrameWnd::LoadFrame()+0107 byte(s)
                                                                                                     0x000000001ED93034, BaseThreadInitThunk()+0020 byte(s)
                                                                                                     0x0000000020C91431, RtlUserThreadStart()+0033 byte(s)
                                                                                                     RAX=0000000000000000  RBX=0000000002AD76E8  RCX=0000000002AD8880  RDX=0000000000000000  RSI=0000000000000000
                                                                                                     RDI=0000000000000001  RBP=00000000B07EBBD0  RSP=00000000B07EB870  RIP=00000000803DCA9D  FLG=0000000000010202
                                                                                                     R8=0000000008FF0C9A   R9=000000005E111CDC  R10=0000000000000000  R11=00000000B07EB6A0  R12=0000000000000017
                                                                                                     R13=000000001F2D6F88  R14=000000000000001D  R15=0000000002AD76E8
                                                                                                     Exception code: C0000005 ACCESS_VIOLATION
                                                                                                     Fault address:  00000001803DCA9D 01:00000000003DBA9D E:\Program Files (x86)\SAP BusinessObjects\Data

Any help?


Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 31, 2018 at 07:50 PM

    Researching this error returned the following KBA's

    1965989 - Designer will not open on one desktop - Data Services

    1904194 - Data Services Designer is crashing on BCGCBPRO100u80.dll - Data Services

    In both instances the resolution is to either redownload the Install package, Install on a new image, or Creating a Windows User Profile that has access rights to Designer.
    The root cause can be the AL_designer.dll is corrupted, not the right file size, or even specific to the security rights or patches of the Operating system Data Services is installed on.
    When comparing the working machine to the failing machine please look for the following differences.

    - Installed Patches
    - Security rights and roles
    - OS updates?

    Add a comment
    10|10000 characters needed characters exceeded

    • Bruno,
      Thank you for testing the new download and trying a different account. Does the local Adminstrator have full rights?
      Have you checked for the differences between the working and failing machines.

      - Installed Patches
      - Security rights and roles
      - OS updates?
      - Installed Visual Studio C++ redistubtion packages?

      In other incidents of this error, point to a security limitation of the installed machine, causing the install not to install fully or a corrupted file. Being that this is production there may be a security settings difference, please work with your System Admin to confirm

  • Posted on Oct 19, 2018 at 03:56 PM

    Hi Jessica!

    Sorry for the delays in responses.

    I checked my machine and the working one, just found some diferences in Installed Visual Studio C++ redistubtion packages, but equalized all of them. Saddlly no good news.
    All the permissions in the two machines are the same, as well as the majority of apps installed.

    Now I'll try a virtual machine and search for other ways. I'll let you updated if I have success.

    Thank you!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.