Skip to Content
avatar image
Former Member

Design Studio: Infochart Label show different numbers

Dear Community

In the SAP Design Studio 1.6.3 I wanna show a Infochart with %-data. If I change from english to german, it shows me two different formats (see attachments).

In the query there is everything fine. That means, if I open the query with a crosstab I get the right format (but not in the chart).

Has anyone an idea how to solve this issue?

Kind regards

1.png2.png

1.png (6.3 kB)
2.png (6.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Nov 10, 2016 at 11:32 AM

    Hi Roman,

    Can you check the format given for your labels in additional properties, Interaction tab?

    Thanks,

    Poovarasan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 10, 2016 at 12:10 PM

    Hi Poovarasan

    Here the settings. What I also found out is, as soon as I insert a normal chart component, the other infochart shows me the right format (xx%). If I hide (or delete) the "normal" chart, I've got the same issue again.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 10, 2016 at 12:14 PM

    Hi Roman,

    Can try giving the format value as ##.##%.

    You will get the required output in chart.

    Thanks,

    Poovarasan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 15, 2016 at 01:12 PM

    Hi that is true but the problem is that I have other measures which are currencies. So then all numbers shows like ##.##%.

    Do you have another idea?

    Best regards

    Roman

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 21, 2016 at 12:10 PM

    Hi there,

    So here are two pic which shows the issue. The OLAP-connection is set "German (Switzerland)" (as in the BW). The same setting are in the BI LaunchPad (Preferred Viewing Locale: German (Switzerland)).

    As soon as I change the "Preferred Viewing Locale" to any other language, so the problem is solved. But we can not live with that. This just happens to Design Studio dashboards.

    Thanks for helping.

    Best regards,

    Roman

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 21, 2016 at 12:28 PM

    Roman - did this issue just start with 1.6? Have you seen Harjeet's blog on the topic? See https://blogs.sap.com/2015/12/30/multilingual-design-studio-application-using-translation-management-tool/

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      I can not really say it. I believe not, but this does not help. It is weird. Although the language is forced from the BO BIP 4.1 - German (Germany) - if I change the language to German (Switzerland) in the BI Launchpad, this has an influence to the language of the dashboard. This means, if I set German (CH) in the BI Launchpad --> wrong format ('0063%). If I set any other language in the BI Launchpad --> right format (63%)

      Any idea?

  • Nov 21, 2016 at 04:00 PM

    Closest thing I could find is this SAP note, although it is related to Web Intelligence - which version of BI4.x are you using?

    SAP Note: https://launchpad.support.sap.com/#/notes/2331778/E

    Add comment
    10|10000 characters needed characters exceeded