Skip to Content

Cannot open Web IDE

Hello,

everytime I try to open SAP Web IDE from the SAP Cloud Platform Cockpit (Neo Trial system - Rot), I get the following error message:

"HTTP Status 500 - An internal application error occurred. Request: 1414257xxx s00xxxxxxxxtrial:webide"

And when I go to "Services" -> "Web IDE" (Tile) -> "Configure Service" I get under "Application Permissions" the response: "Error reading roles: Unauthorized (401)" (see appendix)

I just deleted my Neo Trial subaccount and create a new one to start from Zero. But this does not help.

Yesterday I could use the Web IDE, but today nothing does work.

Thanks for your suggestions.

Regards,

Altan

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Jul 31, 2018 at 11:51 AM

    Have you made any changes in the Trust configuration?

    Are you able to open Web IDE Full-Stack?

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 31, 2018 at 12:15 PM

    Here are my Trust configurations:

    Full Stack Web IDE is also not working...


    trust-1.png (33.7 kB)
    trust-2.png (25.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Aug 06, 2018 at 11:56 AM

    Ido Goren - can you please check this user's subscription to Web IDE Full-Stack?

    Thanks,
    Michal.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 06, 2018 at 12:44 PM

    Hi,

    500 as a response doesn't seem like a missing subscription issue. Could you please send me the account name so I could verify it?

    Thanks,

    Ido

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ido, I have the same issue as Keshav Gupta - I mistakenly deleted my Neo subaccount, and when I re-registered it I can't open Web IDE (and Web IDE Full-Stack). I have Principal Propagation in Trust settings as Enabled, but it doesn't seem to help. How should I proceed?

  • Aug 07, 2018 at 05:46 AM

    Hi Ido, the account name is "s0018xxxxxxtrial".

    Edit: Account name camouflaged.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ido,

      yes, changes were made but then I changed the settings to default. But I think something goes wrong in the internal processes when I set the trust configuration to default...

      Can you maybe reset my configuration to default, please?

      Thanks for reply.

      Regards,

      Altan