Skip to Content
avatar image
Former Member

WEBGUI transaction, in WebClient UI, Table control LineSelect not working

I have custom transaction with table control screen in CTM system, developed using SAPGUI. I launched it using transaction launcher and can execute it from WebClient GUI in CRM 2007. The custom transaction has a table control screen and a subscreen, The mail table control screen has multiple lines with line selection enabled. User can scroll through the lines and select a line and then click a push button. based on the selected line, the sub screen shows a screen related to the selected line. Data can be entered on subscreen and result is displayed on subscreen. However when data is entered on subscreen, even though the selected line is same on the main screen, SAP thinks that the selection in changed and sets the selected line to the 'current line' of table control. This causes a different screen based on new selection on the maion screen displayed on sub screen , instead of displaying the reasults of the data entered on sub screen.

Bottomline is the "On Request' module even though the selection on the main screen is not changed is getting executed, 'INCORRECTLY'

This transaction works without any proble in SAPGUI, but breakes only when executed from WEBClient UI.

Is there a OSS note for this problem? I could not find it

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Apr 15, 2009 at 08:12 PM

    Jatin,

    You might want to do a search in the ITS WEBGUI forums on this topic. Your issue really appears to be related to how the ITS WEBGUI is rendering your dialog transaction and not SAP CRM Webclient.

    I will also try to get this thread moved over for you.

    Thank you,

    Stephen.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 16, 2009 at 06:58 PM

    Thanks, You are absolutely correct. I tried the same using WEBGUI and getting the same result/problem. Thanks for your hemp to move this to the WEBGUI thread

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 16, 2009 at 07:02 PM

    I also tried ITS WEBGUI of CRM 5.0 system, and it works fine there. The problem seems to be for the ITS WebGUI for CRM 2007 system

    Add comment
    10|10000 characters needed characters exceeded