Skip to Content
Jul 29, 2018 at 06:27 AM

Is the AWS ASE Marketplace server not supposed to work after launch?

178 Views Last edit Jul 28, 2018 at 03:59 PM 3 rev

Let me start by saying I do not know SAP and I am trying to get to know SAP ASE.

I launched this Marketplace image

AMI is ami-84d298fb

Upon logging into the instance, i find that sap has failed to start:

Jul 28 15:07:25 systemd[1]: Starting SAP Adaptive Server Enterprise services... -- Subject: Unit ase.service has begun start-up -- Defined-By: systemd -- Support: -- -- Unit ase.service has begun starting up. Jul 28 15:07:25 bash[4787]: /bin/bash: /ase/config/ASE-16_0/install/asesvcs: No such file or directory Jul 28 15:07:25 systemd[1]: ase.service: control process exited, code=exited status=127 Jul 28 15:07:25 systemd[1]: Failed to start SAP Adaptive Server Enterprise services.

I dug into this guide:

And luckily found this:

At deployment, the master and user-specified databases are created by running the following script as the
sybase user:

I tried launching it, of course that didn't work without errors:

[sybase@ip-10-8-11-46 ~]$ ./aws_srvbuild
cat: /ase/config/ASE-16_0/init/sample_resource_files/ No such file or directory
mkdir: cannot create directory ‘/opt/sap/COCKPIT-4/plugins/’: File exists

It sat for awhile, I finally killed the process

^Ccat: /ase/config/ASE-16_0/init/sample_resource_files/ No such file or directory mv: cannot stat ‘tmp1’: No such file or directory

I could then start the server. Is this normal?

Although, when I try to log into the database with

isql -Usa -Psybase123 ipaddress:5000

I get this

ct_connect(): directory service layer: internal directory control layer error: Requested server name not found

I've found articles that include adding a ini/sql.ini file or an interfaces file to include the following data:


Tried restarting. Connecting as isql -Usa -Psybase servername:5000
Didn't help.