Skip to Content
0
Former Member
Apr 10, 2009 at 10:18 AM

Unable to get data for a Generic Datasource

45 Views

Hi Gurus,

I'm working on SAP BI 7.0 with SAP ECC 6.0 as the source system. I happened to create a Generic Datasource ( ZTRANS_DS ) that gets Trasaction Data from a Table ( ZTRANS_CUST). When I'm checking for the availability of data for this datasource is RSA3 its showing the available number of records (i.e., 3). Now when I'm requesting the same data by executing a INIT Infopackage from BI system, I'm not able to get data. Since this is a INIT request with Data transfer, when I'm checking RSA7 for the said datasource its showing 0 records in the Delta Queue.

These are the following things displayed in the Monitor Screen of the InfoPackage.

STATUS TAB :

No data available

Diagnosis

The data request was a full update.

In this case, the corresponding table in the source system does not

contain any data.

System Response

Info IDoc received with status 8.

Procedure

Check the data basis in the source system.

REQUEST TAB :

-> Request (Messages) : Everything OK

-> Data Request Arranged

-> Confirmed with OK

-> Extraction (Messages): Errors Occured

-> Data Request Received

-> Data selection scheduled

-> No data available, data selection ended

-> Transfer (IDocs and TRFC) : Missing Messages

-> Processing (Data Packet): No Data.

When I'm trying to look for Job overview in Source system I'm getting a error popup screen stating " Error while jumping to OLTP System, Error during the retrieval of the logon data stored in secure storage ". I have checked the Source System connection & its OK.

Could someone of you help me out with this issue & provide with a appropriate solution.

Regards,

Syed Shujaath Ali