Skip to Content
avatar image
Former Member

Out of memory error in JDBC receiver adapter

Hi

I am inserting a large data set using a receiver JDBC adapter into a single table in an MSSQL server.

Theoretically I could use statement batch mode to increase throughput. However if I set the batch flag I get an "insufficient system memory to execute this SQL Statement" exception which is apparently being thrown by the jdbc driver.

Question is: Is there a way to allow it to use more memory? Which parameter should be modified and where is it?

Thanx

-Sam.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Apr 02, 2009 at 01:06 AM

    Same answer.. XI is doing what it has to do.. pushing data to SQL server. When the SQL server is not able to take it.. you should try to solve it at the SQL end..!!

    VJ

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 02, 2009 at 03:32 AM

    Hi

    It's puperly MSSQL server issue and handling too. No other parameter can be set in XI to take away that error.

    Try to run the statement from SQL plus and see , contact u r DBA Admin

    rgd

    srin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 03, 2009 at 12:42 AM

    We checked the SQL Server logs and certainly there were out of memory errors. Apparently a Microsoft Hotfix has to be applied.

    Thank you guys!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Samuel

      We have a similar similar scenario of sending huge volume of data into oracle 10g database and are sending in chunks of 10,000 each.Its taking almost 7 mins for inserting into the oracle database.How are you using the batch mode.

      Could you please provide the target message structure used for inserion of data into table.