Skip to Content
author's profile photo Former Member
Former Member

Recording problem

Hello,

I recorded xd01 and before recording I made a tick mark at no batch input session.

When I execute the code which I got from the recording it showing error - "Start screen does not

extist in batch input data".

But when I process the recording its executing properly

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Mar 30, 2009 at 04:16 PM

    Hi ,

    First populate the internal table (type BDCDATA) , then call the transaction xd01 using the internal table.

    CALL TRANSACTION 'XD01' USING TABLE t_bdcdata.

    Regards

    Pinaki

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 30, 2009 at 03:33 PM

    perhaps also handy to put down the BIM code you made.

    then I can verify it with a recording here

    kind regards

    arthur

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 30, 2009 at 03:33 PM

    Hi,

    You need to record unchecking the no batch input session check box.

    If you check the no batch input session and start recording it will not record the first screen so untick and record.

    OR

    If you are using the CALL TRANSACTION to call the XD01 thenu se the OPTIONS FROM statement in the CALL TRANSACTION statement by passing X to NOBINPT field of CTU_PARAMS .

    OPT TYPE CTU_PARAMS.

    CALL TRANSACTION <TCODE> OPTIONS FROM OPT .

    OPT-DISMODE = 'N'.

    OPT-UPMODE = 'S'.

    OPT-NOBINPT = 'X'.

    OR

    If you are using the BDC_INSERT Fm then pass X to NOBINPT of CTU_PARAMS

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 01, 2009 at 11:47 AM

    Hey I had just forgotten one field in bdc_dynpro and that is bdcdata-dynbegin.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.