Skip to Content
author's profile photo Former Member
Former Member

Installation of Crystal Reports Server 2 on Linux 4

I am trying to do a new install on a new Red Hat 4 Linux server. When I run the cabiinstall.sh file I get the following:

Preparing to install...

Extracting the JRE from the installer archive...

Unpacking the JRE...

Extracting the installation resources from the installer archive...

Configuring the installer for this system's environment...

Launching installer...

Preparing CONSOLE Mode Installation...

===============================================================================

Choose Locale...

-

-


1- Deutsch

->2- English

3- Español

4- Français

5- Italiano

6- Nederlands

7- Português (Brasil)

8- Svenska

CHOOSE LOCALE BY NUMBER:

Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

Stack Trace:

java.lang.UnsatisfiedLinkError: /tmp/install.dir.5815/Linux/resource/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(Unknown Source)

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at sun.security.action.LoadLibraryAction.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)

at sun.awt.DebugHelper.(Unknown Source)

at com.zerog.ia.installer.util.BidiUtilImpl.setDefaultLocale(DashoA10*..)

at ZeroGay.a(DashoA10*..)

at com.zerog.ia.installer.LifeCycleManager.j(DashoA10*..)

at com.zerog.ia.installer.LifeCycleManager.e(DashoA10*..)

at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)

at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)

at com.zerog.ia.installer.Main.main(DashoA10*..)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.zerog.lax.LAX.launch(DashoA10*..)

at com.zerog.lax.LAX.main(DashoA10*..)

This Application has Unexpectedly Quit: Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

I have tried with various rights and various user id's. I have also tried having a java runtime 1.4.2 installed and in my path prior to running the install. I have tried the gui and console options both fail with the same error.

Any and all ideas are greatly appreciated.

Thanks,

Mike

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Mar 30, 2009 at 01:47 PM

    Moving thread to Java forum

    Ludek

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.