Skip to Content
avatar image
Former Member

Backup and redo log back up works only with BRTOOLS

Hi!

I am facing with the problem that the backup (online) and redo log backups work only with BRTOOLS commandos (brbackup -f , brarchive -f).

When I schedule the actions from SAP system via tcode DB13, the actions do not work and I get the following errors:

BR0002I BRARCHIVE 7.00 (38)

BR0006I Start of offline redo log processing: aeafgyzd.svd 2009-03-26 13.25.17

BR0484I BRARCHIVE log file: F:oracleSC3saparchaeafgyzd.svd

BR0280I BRARCHIVE time stamp: 2009-03-26 13.25.18

BR0301W SQL error -1012 at location BrDbConnect-5, SQL statement:

'SELECT NAME, NVL(RESETLOGS_CHANGE#, 0), NVL(TO_NUMBER(TO_CHAR(RESETLOGS_TIME, 'YYYYMMDDHH24MISS')), 0), NVL(TO_NUMBER(TO_CHAR(CREATED, 'YYYYMMDDHH24MISS')), 0) FROM V$DATABASE WHERE ROWNUM = 1'

ORA-01012: not logged on

Any helpful information will be very appreciated!

regards

Jürgen

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 26, 2009 at 02:47 PM

    Hello J├╝rgen,

    The difference is the following:

    -> When you just call brarchive -f without any further options, then the user system with the

    default password will be used

    -> When you use DB13 then the default call will be brarchive -u / ... which means that you will logon as

    OPS$ user

    I would now think of a problem with the OPS$ connect. Does it work when you call sqlplus /@adm or do you get an error here?

    Best Regards,

    Michael

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      You may also try like this

      Open Command prompt

      sqlplus /nolog

      SQL> connect /@<SID>

      SQL> exit

      or

      sqlplus /nolog

      SQL> connect /@<SID> as sysdba

      SQL. exit.

      or

      sqlplus "/@<SID> as sysdba"

      Thakns

      Manoj

  • avatar image
    Former Member
    Mar 26, 2009 at 02:33 PM

    hi,

    execute sapdba_role.sql.

    Check SAP note 134592

    regards,

    sachin Rane.

    Add comment
    10|10000 characters needed characters exceeded