Skip to Content
avatar image
Former Member

Deploying a web service to PI 7.1

Hello,

We recently upgraded an XI3.0 system to PI7.1.

On the XI system we had a web service (written in java). It was developed with NWDS 7.0.14 and deployed to XI by SDM using the "deploy" option of the EAR file in the web service perspective.

Aftet the upgrade we wanted to deploy the web service to the new system. However, using the "deploy" option did not work (it ended with an error - SDM host is empty). This was still done with NWDS 7.0.14.

Is there a different way of uploading a web service to PI7.1?

Please note that I only need a server on which the web service runs. I don't need to use a UDDI or to register the service because I refer to the WSDL directly where I use the web service.

Thanks in advance,

Tal.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Mar 26, 2009 at 08:55 AM

    Hi Udi,

    You have to enter the SDM host as the name of your J2EE server with the port. Go to:

    Window -> Preferences -> SAP J2EE engine -> Here Enter the values of Message Server Host and Message Server Port.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      Thanks for your response. I entered the message server host and port. We also checked it isn't a firewall problem. The problem still exists.

      Tal.

  • avatar image
    Former Member
    Mar 26, 2009 at 09:05 AM

    Hi Udi,

    There could be a thousand reasons to this problem. Please go through the checklist , one of them is bound to work.

    1) Verify whether the process table on SAP J2EE server and it says that SDM is running.

    2) You have to enter the SDM host as the name of your J2EE server with the port. Go to:

    Window -> Preferences -> SAP J2EE engine -> Here Enter the values of Message Server Host and Message Server Port.

    3) For some reason the SDM wasn't started by the MMC. Since I was not able to start the SDM via MMC, I started it manually via DOS prompt "StartServer". After that the deployment of the application worked fine.

    4) Try updating the hosts file:

    C:\<WINDOWS-version>\system32\drivers\etc

    Append the following line:

    <localhost IP> name of the localhost.

    e.g.10.590.789.10 remotehost

    Reboot your PC, be sure all threads of the J2EE Engine are running and try to deploy again.

    5) You should use port 39xx instead of 36xx (where xx - SCS instance number).

    6)Please check message server settings on

    visual admin tool:server->kernel->cluster manager

    and check ms.host and ms.port values from the table. If you do your J2ee settings according to these values it will probably work fine.

    The reason why you are getting SDM error is ,at the previous versions there was settings for SDM in preferences and you had to set the port number for SDM ( which was 50018 + 100 * <instance number> ). There is no specific settings for SDM in preferences anymore.

    Regards

    joel

    Edited by: joel trinidade on Mar 26, 2009 2:38 PM

    Edited by: joel trinidade on Mar 26, 2009 2:40 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 26, 2009 at 09:13 AM

    Hi Udi

    For PI 7.1 you have to use JSPM:

    http://help.sap.com/saphelp_nwpi71/helpdata/en/87/4797422930c56ae10000000a155106/frameset.htm

    I have understand that SDM is replaced by JSPM

    Regards

    Abhishek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Stefan Grube

      Thank you Stefan, this solved my problem. I used the same EAR file with the command packsca to create an SCA file to upload with JSPM.

      Unfortunatly, I cannot seem to grant points in this thread.

      Tal.