Skip to Content
avatar image
Former Member

Listener does not start

Hi,

I'm installing SolMng 7.0 on RHEL 5.2 with Oracle.

The Patch 10.2.0.4 is installed and the sapinst stops at the step "Configure Oracle server network"

The problem is connected with the listener, that does not start properly:

serv0101:orasm0 30> lsnrctl start

LSNRCTL for Linux: Version 10.2.0.4.0 - Production on 25-MAR-2009 05:46:24

Copyright (c) 1991, 2007, Oracle.  All rights reserved.

Starting /oracle/SM0/102_64/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 10.2.0.4.0 - Production
System parameter file is /oracle/SM0/102_64/network/admin/listener.ora
Log messages written to /oracle/SM0/102_64/network/log/listener.log
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=SM0.WORLD)))
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=SM0)))
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=serv0101)(PORT=1527)))

Connecting to (ADDRESS=(PROTOCOL=IPC)(KEY=SM0.WORLD))
TNS-12547: TNS:lost contact
 TNS-12560: TNS:protocol adapter error
  TNS-00517: Lost contact
   Linux Error: 104: Connection reset by peer
Connecting to (ADDRESS=(PROTOCOL=IPC)(KEY=SM0))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Linux Error: 111: Connection refused
Connecting to (ADDRESS=(COMMUNITY=SAP.WORLD)(PROTOCOL=TCP)(HOST=serv0101)(PORT=1527)(QUEUESIZE=30))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Linux Error: 111: Connection refused
################
# Filename......: listener.ora
# Created.......: created by SAP AG, R/3 Rel. >= 6.10
# Name..........:
# Date..........:
# @(#) $Id: //bc/700-1_REL/src/ins/SAPINST/impl/tpls/ora/ind/LISTENER.ORA#4 $
################
ADMIN_RESTRICTIONS_LISTENER = on
LISTENER =
  (ADDRESS_LIST =
        (ADDRESS =
          (PROTOCOL = IPC)
          (KEY = SM0.WORLD)
        )
        (ADDRESS=
          (PROTOCOL = IPC)
          (KEY = SM0)
        )
        (ADDRESS =
          (COMMUNITY = SAP.WORLD)
          (PROTOCOL = TCP)
          (HOST = serv0101)
          (PORT = 1527)
          (QUEUESIZE = 30)
        )
  )
STARTUP_WAIT_TIME_LISTENER = 0
CONNECT_TIMEOUT_LISTENER = 10
TRACE_LEVEL_LISTENER = OFF
SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = SM0)
      (ORACLE_HOME = /oracle/SM0/102_64)
    )
  )
################
# Filename......: tnsnames.ora
# Created.......: created by SAP AG, R/3 Rel. >= 6.10
# Name..........:
# Date..........:
# @(#) $Id: //bc/700-1_REL/src/ins/SAPINST/impl/tpls/ora/ind/TNSNAMES.ORA#4 $
################
SM0.WORLD=
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = SAP.WORLD)
          (PROTOCOL = TCP)
          (HOST = serv0101)
          (PORT = 1527)
        )
    )
    (CONNECT_DATA =
       (SID = SM0)
       (GLOBAL_NAME = SM0.WORLD)
    )
  )
serv0101:orasm0 33> cat sqlnet.ora
################
# Filename......: sqlnet.ora
# Created.......: created by SAP AG, R/3 Rel. >= 6.10
# Name..........:
# Date..........:
# @(#) $Id: //bc/700-1_REL/src/ins/SAPINST/impl/tpls/ora/ind/SQLNET.ORA#4 $
################
AUTOMATIC_IPC = ON
TRACE_LEVEL_CLIENT = OFF
NAMES.DEFAULT_DOMAIN = WORLD
# 05.01.06 unsorported parameter now
#NAME.DEFAULT_ZONE = WORLD
# 05.01.06 set the default to 10
SQLNET.EXPIRE_TIME = 10
# 05.01.06 set to default
#TCP.NODELAY=YES
# 05.01.06 set to 32768
DEFAULT_SDU_SIZE=32768

I checked note 396873

serv0101:orasm0 34> ls -la /var/tmp/
total 20
drwxrwxrwx  3 root root 4096 Mar 25 05:08 .
drwxr-xr-x 22 root root 4096 Mar 23 04:35 ..
drwxrwxrwx  2 root root 4096 Mar 25 05:46 .oracle

What could be the reason?

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 25, 2009 at 11:36 AM

    Hai,

    Did you make any changes to the /etc/hosts file?

    Possible problem is that the "localhost" entry is missing or wrong in /etc/hosts file.

    Add or check the localhost entry in /etc/hosts file to be as follows:

    127.0.0.1 localhost.localdomain localhost

    Regards,

    Yoganand.V

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 25, 2009 at 12:52 PM

    Great! Thanks!

    Add comment
    10|10000 characters needed characters exceeded