Skip to Content
avatar image
Former Member

Message code and function problems

Hello all,

we have the following problems with message codes and functions.

We hava a mapping on XI server, where we are transforming source data into iDOC.

We fill in fields message code and message function during mapping, but when the iDOC

arrives at SAP R3 system, these fields are empty?

Do you have some similar experience or do you know what could cause this problem and how to fix it?

Thank you very much.

Zahir

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    Mar 24, 2009 at 10:12 AM

    Hi Zahir,

    Can you check if the "Apply Control Record Values from Payload" indicator in the receiver IDoc adapter is checked.

    In your case this has to unchecked as you already have a mapping for message code and function.

    Thanks.

    Regards,

    Divya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 24, 2009 at 09:57 AM

    Hi,

    are the fields also empty when checking message processing in XI via SXI_MONITOR / SXMB_MONI? Also in IDX5?

    Regards,

    Kai

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 24, 2009 at 10:42 AM

    chk /people/michal.krawczyk2/blog/2005/09/01/xi-idoc-adapter--edidc40--demystified

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 24, 2009 at 12:56 PM

    Yes, thanks, it works 😊

    zahir

    Add comment
    10|10000 characters needed characters exceeded