Skip to Content
avatar image
Former Member

Error Wrong partner type LS

Hi All,

I am doing IDOC to File Scenario where i am sending Purchase order details to third party system. When i create or change the PO it should generate ORDER05 idoc and send to PI. I configured output type to generate PO idoc but it is not generating idoc. Configured details is as below

Output type :NEU

In General tab:Access to conditions and multiple issuing is checked

Default value

Dispatch time: Send immediately

Transmission medium: Distribution ALE

Partner function: LS

Processing routines: Distribution( ALE ) RSNASTED ALE_PROCESSING

Partner function:Distribution( ALE ) LS Logical System

Procedure: RMBEF1 Purchase Order.

I activated this procedure in SPRO Tcode

In condition record

I choosen purchase org option and gave the following details.

Pur Org: RS00

Function: LS

Partner: XXXXX001

Medium :A

Date: 4

I did configuration in partner profile by adding orders details and message control details in in XXXXX001. I also configured Distribution model.

When i create PO the above mentioned condition records are coming in the message type. when i check process log in me22 it says Wrong partner type LS The message record of the message control contains a partner role with a partner type LS that cannot be used here. Only the 'KU' and 'LI' partner types are allowed

i used this as reference

www saptechnical com/Tutorials/ALE/AutoIDOCGen/AutomaticIDocGeneration2.htm

I have searched entire SDN form no one has given correct answer. Please let me know what is the problem.

Thanks,

Venky

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Mar 20, 2009 at 07:40 AM

    Please go to WE20 and check the system entry there. Is it defined as logical system (LS)?

    Thanks,

    Kai

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 20, 2009 at 07:44 AM

    hi,

    how to send PO from SAP with all screenshots and details

    can be found here:

    www.sap-press.com/product.cfm?account=∏uct=H1935

    there is no need to search all SDN just the book 😊

    Regards,

    Michal Krawczyk

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Michal Krawczyk ,

      I have gone through that book it explains Output configuration for partner function VN. How to do configuration for Partner function LS. As i need to send to XI. Please Explain

      Thanks,

      Venky

  • avatar image
    Former Member
    Mar 20, 2009 at 11:41 AM

    Is any body know the answer

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 26, 2009 at 03:15 PM

    I think purchase orders can be sent only to partner types vendor and plant not LS ( or am i missing something ??)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Shankar,

      Goto-> ME21N-> in item level you find Conformation Tab-> below that you need to check the check box and save the configuration. If you dont know pls see sap help or an MM fuctional consultant to get some help.

      Where can i find this conformation tab i searched for this tab, didn't find any. Can u plz elaborate the same or else give the sap help link. I don't have any MM Consultant to help on this issue.

      Thanks,

      Venkatesh

  • avatar image
    Former Member
    Mar 30, 2009 at 07:52 AM

    Hi Venkat,

    In ME21n -> in item level you can fine Confirmation Tab goto that and in the bottom check the Order Ack Check box.

    Note: While creating a PO this particular configuration need to be always activated in order to get the Order confirmation/response.

    Hope this helps

    Regard

    Shankar.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Shankar,

      I did the changes but still I am getting the same error " Error Wrong partner type LS".

  • avatar image
    Former Member
    Mar 30, 2009 at 10:41 AM

    Venkat,

    Then your ALE setting are not done correctly. Check the TCode SM58 for any errors .

    Follow step by step procedure for ALE Configuration.

    One more thing is in BD64 have to generated the Partnet Profiles?

    Regards

    Shankar

    Edited by: Shankar on Mar 30, 2009 12:42 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Shankar,

      ALE configuration is perfect, I used we19 to create Orders05 idoc are generated successfully and sent to XI system. So there is no problem with ALE configuration.

      Thanks,

      Venkatesh

  • avatar image
    Former Member
    Mar 30, 2009 at 11:53 AM

    Hi venkatesh,

    Here are the details of the ALE configuration for sending the IDOCS to FILE.

    SAP:

    1. RFC destination to XI system.

    2. Check the message type.

    3. create the logical system ( hope this is created if you are working in any projects )

    as this is a one time activity and is done by the basis team at the time of post installation process.

    LS ---> SAP

    LS1--->XI

    3. define a port to send the IDOCS.

    4. go to WE 20. create a partner profile. and provide the message type in the outbound parameters.

    and provide the port details.

    5. Create a CDM(BD64) and provide the details.

    XI:

    1. Create an RFC connection to SAP system.

    2. Define the port details from IDX1

    3. upload the meta data from IDX2.

    go to WE19 and generate the IDOCS and see if the IDocs are sucessfully send to the port or not from WE02.

    Check in XI side if the IDocs hits or not.

    Thanks,

    Jay

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Please check this:

      In customizing of the condition technique

      Sales and distribution --> basic functions --> output --> output determination --> output proposal using the condition technique --> maintain output determination for deliveries --> maintain output types

      Choose your output type (e.g. LD00) and click on detail. On the next screen is a field called "partner indep.output". This field has to be marked!!

      Because of this checkmark the "partner function" on this screen should be empty!

      Alternative:

      Create a partnerrole (TPAR-PARVW) " " (space) and partnertype (TPAR-NRART) "LI".

      When the output type is copied into the document it should look something like this

      message type LD00

      medium A

      Role " " = empty

      Partner " " = empty

      Language "E"

      Regards,

      Kai