Skip to Content
avatar image
Former Member

Backward Compatibility of Adobe forms

hi all,

I am developing Adobe forms for WD ABAP environment. I am using Adobe Live Cycle Designer 8.0 and Adobe Reader 8 for developing and testing those forms.

But when my forms are delivered to the users, who not necessarily run Adobe Reader 8, most of my interactive features dont work.

How can i make my form backward compatible to older versions or atleast let the user know that some features might not run properly in the version they are using....??

All help will be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Mar 18, 2009 at 11:15 AM

    Hi,

    check SAP Note 834573 - SAP Interactive Forms by Adobe: Acrobat/Reader version

    Regards,

    kaushal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kaushal,

      Thanks for the Note, it has helped me answering the client, but still can we by someway get the Adobe Reader version in the users system and may be display a message box that some fields may not work properly or may be askthe user to update the Adobe Reader version...???

      And if it is possible will be it done in FormCalc or in my WebDynpro Component...?

  • Mar 18, 2009 at 07:14 PM

    I have had this handled two ways on 2 diff projects/clients:

    1. Admins run a "sweep"/check of all workstations and will "auto/stealth" update Reader versions to needed level.

    2. Code added into corporate portal that detects Reader version on desktop and will then display a page with a warning for what level is needed as well as a link to go download.

    Add comment
    10|10000 characters needed characters exceeded