Skip to Content
0

static database parameter should not be left empty

Jul 11 at 04:27 PM

58

avatar image

I don't want the user to leave blank for static db parameter, a value must be entered. How we implement that in CR 2013. right now i am able to

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Abhilash Kumar
Jul 11 at 05:16 PM
0

Hi Neha,

Right-click the Parameter field > Edit > Scroll down and look for an option called "Min Length".

Type in "1" in the text box beside (without the double quotes).

-Abhilash

Show 1 Share
10 |10000 characters needed characters left characters exceeded

it worked. Thanks Again

0
Dell Stinnett-Christy Jul 11 at 05:18 PM
1

First, you need to make sure that the parameter definition is not set to "optional".

Do you have a static list of values you can use for the parameter? If so, then make sure "Allow Custom Values" is set to false in the prompt definition. This will force the user to select from the list.

If there is no list of values, then set the edit mask to "A########" with as many "#" characters as you need for the maximum length of the expected response. If the value the user needs to enter is a number, then you'll use "9" in the edit mask instead of "A". This will force the user to enter at least one non-space required character into the parameter.

-Dell

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thank you Dell

I tried to implement the solution. It was for 2 number digits. So I entered "99". CR kept asking for 9. I am not i was implementing that correctly

0

Did you include the quotes? If so, take them out because they mean that it will expect 9 instead of any number.

-Dell

0
Neha Jaiswal Jul 11 at 09:25 PM
0

Thank you Abhilash - that was easy to implement.

Share
10 |10000 characters needed characters left characters exceeded