Skip to Content

Show explanation by defaul ("Display Quick Help")?

If I put an explanation element on a web dynpro view, and if I use the design "Emphasized", it is disabled by default. To see it, users have to right click and select "Display Quick Help".

Is there a way to display, not hide, such an explanation by default?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 16, 2009 at 09:08 AM

    Hi Daniel,

    Use following code in 8WDDOMODIFYVIEW* Method.

     data text               type string value 'Help Text'. " Give the text here
      data wad_formatted_text type ref to cl_wd_formatted_text.
      data ui_explanation     type ref to cl_wd_explanation.
    
    
      ui_explanation ?= view->get_element( 'EXPLANATION' ). " Give the ID of your expalanation UI
      ui_explanation->set_text( text ).
    
    

    It will set the text even if You have selected design as 'Emphasized'.

    I hope it helps.

    Regards,

    Rohit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 09, 2013 at 09:38 AM

    You can use the following code in WDDOMODIFYVIEW. It will never let user disable the quick help.

    DATA api_main2        TYPE REF TO if_wd_view_controller.

       DATA component        TYPE REF TO if_wd_component.

       DATA application      TYPE REF TO if_wd_application.

       api_main2 = wd_this->wd_get_api( ).

       component = api_main2->get_component( ).

       application = component->get_application( ).

       application->set_show_explanation( abap_true ).

    -Manish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 13, 2009 at 05:32 PM

    Hi Daniel,

    i just checked by default Explanation gets displayed!! i am on SAP BASIS 7 sp13. Only after i chose to hide , we need to right click & chose show help!!.

    Greetings

    Prashant

    Add comment
    10|10000 characters needed characters exceeded

    • Did you try design=emphasized as well? Was it shown by default as well?

      If so, then there must be a setting on component or application or user level to show/hide explanations.

      Any idea where?

  • Jun 02, 2010 at 06:21 PM

    Hi,

    is it possible to force the help text display?

    If a user hides the help, is it possible to have it always open when he enters the application?

    Another option would be to have a report to clear this personalization of the user, does this exists?

    Thanks,

    Paulo Ruivo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      A couple of days ago I was looking the way to solve this, google brought me to this post more than once but I couldn't find the answer and I gave up. I was looking how to solve another completely different issue and accidentally found the answer navigating through the interface definitions so I came to post it. This code will show all quick helps whenever executed (from component controller):

      {code}

      data: app type ref to if_wd_application,
              comp type ref to if_wd_component.

        comp = wd_this->wd_get_api( ).
        app  = comp->get_application( ).
        app->set_show_explanation( abap_true ).

      {code}

      Hope it will help someone.

      Regards.

  • avatar image
    Former Member
    Feb 18, 2014 at 07:34 PM

    Hi,

    I am trying to force the Quick Help to Display by default the 1st time an end user logs into the portal.

    I tried changing the application parameter WDHIDEMOREFIELDHELPASDEFAUL and that did not work. The Quick Help does not display on by default.


    Can this be done without any code??

    I see some posts on here with some code to force it override if the end user closes it. I do not need to do that. I just need it to default open the first time an end user logs in.

    Can anyone help?

    Thanks,

    Sherri

    Add comment
    10|10000 characters needed characters exceeded