Skip to Content
0
Former Member
Mar 09, 2009 at 07:36 AM

JSPM error......can I do a manual upgrade?

18 Views

Hi there,

We have installed SAP PI 7.1 on an iSeries server. The installation was fine but we cannot get the JSPM to work correctly. The error in question is:

The execution ended in error (BTW: I have posted this error to 2 other forum discussions....no reply yet....)

Cannot initialize application data.

Could not detect operating system.

Cannot determine OS version from command uname.

I have a customer message open with SAP on this but the irritating thing is they say we must upgrade our JSPM to the latest version before they will look further BUT you need the JSPM to be able to upgrade itself and our JSPM will not start properly!

Here are the version details:

JDK version........: 1.5.0 IBM Corporation

JSPM version.......: 7.10.4.0.2.4.9

System release.....: 710

ABAP stack present.: true

Can someone please advise me how to upgrade the JSPM to the latest version manually? I cannot do it through the JSPM itself......can I not just unpack the latest JAR files or something over the current files?

Any help or advise would be greatly appreciated

Kind regards

Lynton