Skip to Content
0
Former Member
Mar 05, 2009 at 11:59 AM

Database fields empty after creating a new (Crystal) Report in MSY

23 Views

Hello,

I have some issues to use Crystal Reports in Mobile Sales Maintenance (MSY). The situation is as follows

My example is based on this standard report, which is working

Report Name: BPartnerActivities

Reporting Tool: Crystal Reports

Category: Standard reports

Subcategory: Lists

Report Type: Report

Data Source: Business Content provider

Business Content Provider: BPActivities

My requirement is to build a new report, which is based on the standard "BPartnerActivities" Report. If I use the "copy" functionality, I get an working Copy of the standard report. However, I need to modify the Business Content Provider, but I do not want to make the modifications on the standard content provider "BPActivities".

I am now forced to used the "copy" functionality to create a copy from "BPActivities" for my own Content Provider "My BPActivities copy", which I want to use in a new report.

Issue:

I cannot modify the defined Business Content Provider after using the "copy" functionality and hence forced to create a new report from scratch to be able to set a different Content Provider.

I create my own report "MyBPartnerActivities" based on the standard report "BPartnerActivities" using the same settings and assign my new business content provider.

If I use the "Design Report" or "Modify Report" button, the Crystal Report designer pops up. Now the problem, the Crystal Report designer does not offer me any data below "Database fields".

In the standard report, the "Database fields" has a child element "BOACTIVITY-ttx" with several field options. My own created report from sratch does now have anything?!

Why my report does not offer my any data or is there anything additional to do?

Another Test

I tried to create another report using the standard content provider "BPActivities", but I have still the same issue.

In addition I recongized that the "browse data" fuctionality does not work on the fields in the standard report. The path to the database file does not exist. It starts with "C:\WINNT\...", but my system has "C:\WINDOWS\...". But the executed report is able to retriev the data?!

Unfortunately was not able to find any proper documentation, but I would really appreciate any help.

Regards,

Andreas