Skip to Content
author's profile photo
Former Member

Maintaining PPO settings conflicts with vendor creation

Hello,

I am facing a strange issue. We are working on ECC 6.0 and we have REFX implemented. Also we have followed the note 956054 and made all the configurations mentioned in it for customer-vendor-business partner integration.

Now, when one of my colleagues tried to create a vendor using the transaction code XK01, she could fill up all the fields successfully. But, when she clicked on the SAVE button the system generated a short dump.

Upon analyzing the short dump it was found that it was coming due to a setting mentioned in the Note 956054. Under point 1.2 of the note, the procedure for setting up the PPO is mentioned. And it has been found that the short dump is coming only because of this configuration of the PPO.

Can someone please throw some light on how to resolve this?

Regards,

Suvarghya Dutta

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Mar 04, 2009 at 11:22 AM

    Hi,

    if there are errors while update in the CVI there are two possibilities:

    1. PPO is not activated

    Then a short dump is raised and it is possible to navigate in the dump to the variables that contain

    further information about the dump (that is described in note 956054)

    2. PPO is activated

    No dump occurs and you have to check transaction for post-processing regularly if there are entries in the log because of updates that were not successful.

    In a productive environment it is not suggested to activate PPO because that may lead to data inconsistencies. PPO is only thought for better error handling.

    I prefer method 1., because you know immediately that something is wrong, you get no data inconsistency and by navigating in the debugger it is easily possible to find out the reason.

    Regards, Franz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Franz Posch

      Hello Franz,

      Since our users are now able to create Customers/vendors successfully, I understand there wont be anything wrong if i uncheck the PPO activation. Many thanks for the information.

      Kind regards,

      Suvarghya Dutta