Skip to Content
author's profile photo Former Member
Former Member

print should come only once per document number

Hi All,

I have done a script for the WC Document,

But now the client requires it to print it only once for a particular document number,

How can we do. Is there any such coding to restrict the print only once per document.

If anyone knows the solution please post it

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2009 at 04:18 AM

    hi,

    what u can do is, create a ztable with entries of document number and a checkbox.

    every time u execute the script check whether the particular doc number has already been executed or not. if yes then give error message or else process ur script and update the ztable with the current entry.

    кu03B1ятu03B9к

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2009 at 04:35 AM

    hi

    to add on what kartik suggested just put check in that ztable once your document executed.

    save document no. and with flag set 'X'.

    and before printing the form . select the doc no. in the table if found then no need to print the form.

    else go ahead.

    this way you can skip the check field also.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2009 at 07:35 AM

    hi

    check the entry in nast table if you find more than 1 enrty that is repeated print .....

    select objky

    kschl

    erdat

    eruhr

    vstat from nast into table gt_date

    where objky eq gv_del_num. ---> document number

    if sy-subrc eq 0.

    sort gt_date by objky erdat descending .

    describe table gt_date lines lv_n.

    if lv_n gt 1.

    gv_repeat = lc_x.

    endif.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 26, 2009 at 05:22 PM

    If you're using the standard output functionality, then this may be accomplished by a change in the output type (transaction NACE). There is a checkbox 'Multiple issuing'. If it's unchecked, the output will be issued only once.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.