Skip to Content
avatar image
Former Member

High processing time and low CPU time - maximum workprocess holdtime exceed

Hi,

We have approx 5 times a day a GUI abort "maximum workprocess holdtime exceeded" (within different transactions)

If I check the stad records I see the following:

Example1:

Response time: 61.079 ms

Processing time 61.077 ms

Load time 1ms

DB request time 1 ms

CPU time 16 ms

(all other values are zero)

Is it possible that this is caused by frontend network communication problems?

Because we have a network problem (at the moment we are checking the reason) and sometimes we have high roll wait times due to this. It's no problem to identify the records within the stad.

But I don't know the reason for the time in example 1. Is there maybe a correlation to the network problem?

Thank you for your help!

Kind regards,

Frank

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 25, 2009 at 09:51 PM

    Hi,

    If you have network related problem then please check below mentioned 2 SAP notes.

    Note 500235 - Network Diagnosis with NIPING

    Note 1100926 - FAQ: Network performance

    If you have high response time (ST03, ST07, STAD) then please check below SAP notes

    Note 1014072 - High response time in transaction STAD or ST03 or ST03Nb

    Note 8963 - Definition of SAP response time/CPU time

    Note 376148 - Response times without GUI time

    Note 805934 - FAQ: Database time

    Note 110686 - Different response times ST03, ST07

    Also below links may help you.

    http://help.sap.com/saphelp_nw04/helpdata/en/21/2c8f38c7215428e10000009b38f8cf/content.htm

    http://help.sap.com/saphelp_nw04/helpdata/en/25/ece73a39e74d27e10000000a114084/frameset.htm

    Thanks,

    Sushil

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 25, 2009 at 04:10 PM

    This happens when the value in the following parameter is exceeded:

    rdisp/max_wprun_time

    I usually have seen this happen when users try to run things in the foreground that should be background jobs.

    I haven't seen it be because of network but it kind of makes sense if your network is really, really slowing down.

    The trick here will be to figure out if the faults are truly random, which you can blame on network, or if they relate to what the user is actually doing. You have to balance between the possible performance issues of making this larger and your customer's needs.

    By default, this is 600. My previous client insisted it stay there. My current client keeps it at 1800. Since this is a dynamic parm, you can play with extending it without bouncing.

    good luck.

    Add comment
    10|10000 characters needed characters exceeded