Skip to Content
author's profile photo Former Member
Former Member

maintenance view- package in another system

Hello all!

I'm trying to create a maintenance view for a Z table, but i can not do it because i get an error message that says: "The original of the table development class YMMI is in DEV". YMMI is the package, but DEV is not the development system of this client, but the one of another client, where data comes from (i think there was a kind of transport). In table attributes, it says: Package: YMMI, but i am not allowed to change this. SAP version is 4.6 C.

To do this, i go to se11, enter table name, then modify, and then utilities--> table maintenance genarator.

(This version doesn't have the part Delivery and maintenance). The same occurs when entering from SE54.

Please give me an idea!!

Thank you!

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 25, 2009 at 09:56 AM

    delete the old table maintenance and create new table maintenance and save it your package.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 25, 2009 at 10:06 AM

    hi

    Change the object directory entry with se03.

    Gr., Frank

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 25, 2009 at 11:30 AM

    Hey maitas,

    You check the Display and Maintenance table whethere is the is maintainable or Maintenace Not allowed. If the option is Display/Maintenance Display/Maintenance Allowed with Restrictions or you can create the maintenance view otherwise you cannot create.

    Regards,

    Saravanan M

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Saravanan, the check box Table maintenance allowed is activated. I'd like to find the way to ignore that error ("The original of the table develoment class YMMI is in DEV") I can not enter DEV system and create maintenance view there, I think it would work in that way, but DEV system is now independent from this one, maybe they don't want to have a maintenance view, do you understand?

  • author's profile photo Former Member
    Former Member
    Posted on Feb 25, 2009 at 06:08 PM

    I went to se11, create a new maintenance view, and then established a relation between this view and the proper table.

    The only thing, is that now, in sm30, field names appear with "+" instead of the name. It is happening for almost all fields, it is just showing 3 names. The view is working fine (it loads data in table) but you have to guess which field you are filling

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.