Skip to Content
Former Member
Feb 19, 2009 at 10:46 PM

Web service problem



I've made a WS on a ECC6 SP14 via SOAMANAGER and generated a WSDL.

With this WSDL, i've made 4 test with it :

1. I've picked the soap address within the WSDL, put it in my IE and i've got this message :



<faultstringxml:lang="en">SRT: Wrong Content-Type and empty HTTP-Body received </faultstring>






<Exception_Text>SRT : Wrong Content-Type and empty HTTP-Body received</Exception_text>



2. Thru a .NET application but it gives the same error message than above.

3. Thru SOAPUI and XMLSPY and it seems "fine" but my response content is the same than my request so i think something is weird...

4. I've tried also with WSNavigator but i've got an error message which says :

"Cannot download WSLD from http://<server>:<port>/sap/bc/srt... its not allowed to access this service.If you believe you should be able to, please contact your administrator"

I have SAP_ALL and SAP_NEW so how can i have an authorization problem ??

Like you see, i've tried many things but i've lost somebody got an idea ?

Is someone have an idea plz ?

PS : By the way, hhen i look in t-code SICF(on ECC), i don't see my WS in sap/bc/srt/rfc/sap/z**/client/z*/z* , is it normal in SP14 now ? Even if there are "obsolete", i don't see either my WS in WSCONFIG..

Thanks by advance