Skip to Content
avatar image
Former Member

Error in RWB while trying to create TREX indecies

I'm trying to integrate the RWB with TREX for message search. I've followed all the steps for doing so, but when I try to activate indexing for the Adapter Engine I receive the following error:

An error occurred: Class: com.sap.aii.rwb.web.trex.CentralTrexException : Message: ProcessorException in Method: CentralTrexManager: activateIndex( String ). Failed to activate Trex service. SOAP-Actor: http://sap.com/xi/XI/Message/30; fault String: TrexException in Method: TrexProcessorBean: activateIndex( TrexProcessorConfigurationData ). Thrown by any problem related to the TREX configuration processing. Message: Class: com.sap.aii.af.service.trex.TrexException : TrexException in Method: TrexManager: isIndexAvailable( String, String ). Failed to check if the index: xi_msg:af.xd3. is available on the Trex server. Message: Class: com.sap.aii.af.service.trex.TrexException : cannot send XML request to http:// :3xx05/TREX; reason: ; QName: TrexProcessor; Message: com.sap.aii.af.service.trex.proxy.ProcessorException

The integration engine shows green, but then, when 'refresh' is clicked, returns:

An error occurred:1) Class: com.sap.aii.rwb.web.trex.CentralTrexException : Message: TrexException in Method: CentralTrexManager: getDocumentCounter( String ). TrexException: Failed to return the number of indexed documents for Trex index: xi_msg:is.50.<pi hostname>. Message: Class: com.sap.aii.af.service.trex.TrexException : TrexException in Method: TrexManager: getDocumentCounter( String ). Failed to return the number of indexed documents for Trex index: xi_msg:is.50.<pi hostname>. Message: Class: com.sap.aii.af.service.trex.TrexException : cannot send XML request to http://<TREX short hostname>:3xx05/TREX; reason: <TREX short hostname> ;

The /ntrexadmin transaction shows green across the board. The required ports have been opened for two-way communication. Monitor variable has been set in sxmb_adm. The RFC to TREX passes the connection tests. 'nameserver.address' in the VA has been set to "tcpip://<FQDN of TREX>:3xx01" and 'nameserver.backupserverlist' is set to "tcpip://<IP address of TREX>:3xx01"

xx = system number

<value> = actual value and removed from post for security reasons.

Any help will be greatly appreciate and points awarded for useful information and/or answer.

Best Regards,

Wesley Tobler

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Feb 18, 2009 at 03:24 PM

    This looks a lot more complicated than it really is. A simple change to the hosts file to reflect IP Address, FQDN and Host name (or short name) of the target TREX server resolved the issue. For some reason, RWB tries to call TREX via http://<host name>:<port number>/TREX rather than by the IP address or FQDN.

    Add comment
    10|10000 characters needed characters exceeded

    • Hey

      Even i m getting the exact same error when i try to connect to Trex from PI system

      I have added the following entry to my local dekstop host file,but i m still getting the same error

      XX.XXX.XX.XXX <Hostname>

      Could you please let me know how you added your entries.

      Thanx

      Saif

      Pl:XX.XXX.XX.XXX is the Ip address of my TREX server and <Hostname> is its hostname.

  • avatar image
    Former Member
    Feb 28, 2012 at 10:44 PM

    The FQDN is the issue for this. I have resolved this in the below manner.

    1. Make sure you did not maintain FQDN in the NWA TREX host:port settings.

    2. I found that when I try to activate the Idexing on Adapter Engine (RWB), it is making a call to the TREX engine with the URL http://Hostname (FQDN):36005/TREXHttpServer/TrexIsapiExt.dll . This is the URL where my http service on TREX is running. You can check this from TREX admin tool ->Landscape->services tab.

    3. On TREX Admin screen, goto "Landscape->ini" tab, Look for "TREX Webserver" file and change the hostname from FQDN to just hostname.

    4. restart the TREX engine/ host and try activating it again from RWB.

    This should work.

    Thanks,

    Pradeep

    Add comment
    10|10000 characters needed characters exceeded