Skip to Content
author's profile photo Former Member
Former Member

Attachment transfer issue from Shopping cart to Purchase req in ECC


How are you all. Need your expert advise..

We are trying to achieve functionality where documents which are attached on shopping cart get transfer into Purchase req in ECC (Classic Scenario with SRM 5.0 and ECC 6.0). For this we have done following config / enhancements:

- Activated BADI "BBP_CREATE_BE_RQ_NEW" in SRM with following code for attachment;

cs_ctrl_att-BE_DOC_TYPE = 'SRM'.

cs_ctrl_att-BE_storage_cat = 'DMS_C1_ST'.

cs_ctrl_att-TRANSFER_ACTIVE = 'X'.

- Created new document type ECC with t.code DC30 for SRM and assigned the object links for EBAN table.

After performing above task we are able to see Link of the attachment into Purchase req in ECC with document number (i.e. the one we assigned while defining document type in DC30) but not able to open the document in ECC.

Could you please let us know if there is any settings which we have missed for actually opening documents in ECC?

Thank you


Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Mar 26, 2009 at 06:19 PM

    Resolved it...

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ritesh,

      I am using SRM 7.0 and while i create an attachment in shopping cart and try to send it in ECC, the attachment is not reflecting .

      I see that you have resolved it kindly please provide the details code.

      Since we are using the latest version of SRM, we have used BADI BBP_CREATE_BE_RQ_NEW


      I have also gone through the below link and tried the implementation :

      Also, all ECC configuration are in place. However things are not come in place. Only the details are reflected but the attachment is not

      reflected in ECC.

      If you can guide the correct way in SRM BADI along with ECC configuration (just to verify) will be a great help.

      Kind Regards,


  • Posted on Oct 07, 2013 at 04:05 PM

    Issue as reported Please let me know why the docs are not uploaded to SRm succesfully .

    I am facing the below weird issue .

    Easy shopping >Shop> eHiring catalog

    Click Transfer to SRM

    Now click on the button ‘Details’ and open the tab ‘Notes and attachments’

    All attchments are names after the 1st attachment and all have the same file type

    Basically you have lost all you attachments here, except 1 (when you click on the link, all links refer to the same document, so not just cosmetic). This is a problem.

    When you order this shopping cart and search for it and open it again, the attachment tab is even completely empty, so now all attachments are lost.

    Something like this, but less severe, happens in the process a bit further.

    • - Approve the shopping cart with the applicable approver
    • - Log in as Hiring desk:

    Still no original attachments (like job descriptions).

    Now click button ‘responses and awards’

    Click tab ‘Items’ and fill out price ‘40’ euro

    Click notes and attachment tab

    I added 5 attachments

    As can be seen here, the docx becomes an xlsx again, but it looks like it just takes over the 1st file type that was uploaded, it can also be the other way around (xlsx becomes docx) when the 1st uploaded attachment is a document.

    But in this case, when you click on the link, it will open the right file with the right program, so over here it looks like it is just cosmetic.

    Add comment
    10|10000 characters needed characters exceeded