Skip to Content

Pricing Date Problem in OR Doc.

Please help me for the below mentioned problem I am facing in VA01.

In VA01, a pricing date which is showing presently is a date of 2004. If I changed that manually the pricing date and req. delivery date both system gives a massage-- " System fail to copy schedule line date " and new date which is changed manually is not copied all the documents. As a result delivery is created (VL01) but no PGI is happening. Massage shows----- comapny code____ accept only current posting period in Error log.

I am using R/3 4.7 version.

Factory calender properly maintained in MM01 and sales organisation with a validity period from 1990 to 2015.

Please help at your earliest !!

regards,

Arindam

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Feb 16, 2009 at 03:13 PM

    Hi Arindam

    First of all check in MMRV , in which month & year your company code is existing .Because as per that only you will be getting the pricing date , delivery date .

    If your company code is in past then close the period by MMPV

    Secondly in VOV8 , select your document type and check the date format & date type . feilds are they blank or maintained . If maintained , keep it blank

    Regards

    Srinath

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 18, 2009 at 08:37 AM

    Hi,

    go to OMSY and check the month and year which system shwoing for ur co code. if it falls back update it month by month by using the transaction code MMPV

    regards,

    sadanandam kasarla

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 19, 2009 at 02:52 PM

    Dear All,

    Thanks a lot for your replies.......But it's not work for my issue. I just mention once again my problem for ur help !!

    1. Pricing date on VA01 shows a date of Dec. 2004 and if I change the date I am able save the order but in VL01 no PGI is not possible for old date issue. Error log shows .......company code .xxx . posting period of 02/2009 to 01/2009 only. Even after changing document date manually old document date showing at VL01.So NO PGI is possible for this date issue.

    2. MMRV shows current posting period.

    3. Factory calender properly assigned with a validity period of 2008 to 2015.

    4. OMSY shows current posting period for company code.

    5. In VOV8, pricing date filed is blank.

    Please help for this issue......need ur advise asap.

    regards,

    Arindam

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Arindam

      -> Check what factoy calendar has been assigned to the shipping point .

      -> Also check in the sales order , item data ->shipping tab ,what delivery date is coming .

      -> Also check wheather What plant and shipping points are coming in the sales order

      -> Check what calendar year has been maintained in shipping point and sales orgn. , Both are same or different , just check that data also.

      Regards

      Srinath

  • Feb 24, 2009 at 06:09 AM

    Dear All,

    Please put ur valuable opinion about this issue. As per all the SAP Gurus told b4 this feedback I tried all of them but in vain......no solution is coming.

    If I change the date manually in VA01 "date created on"....shows the old date of 2004.

    regards,

    Arindam.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 26, 2009 at 02:35 PM

    Hi,

    If the system is saying that Posting is possible between so and so period at PGI,the possibility is that the current period is closed. Please go to MMPV and close the present peroid by entering the company code, period and fiscal year and selecting check and close period.

    Regards

    Ram Pedarla

    Add comment
    10|10000 characters needed characters exceeded