Skip to Content
author's profile photo Former Member
Former Member

Sorting Data

Hi All (any help will be appreciated)

Sorting Data in Business Objects modify view is just like sorting in excel, However in the view where you would just click on the report name you want to open, there does'nt seem to be a sorting option.

My problem is i have set up a report with prompts for dates and agent names. However when i clcik on agent name promt to select a single name the list of names in the report is not in order but in modify view it is. i tried to refresh to see if that would work but it didnt.

Does anyone know how to correct this? it may be something really simple that i am not seeing!

Thanks very much

Kelly

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 16, 2009 at 01:09 PM

    Hi Kelly,

    If you are using Interactive View you can sort the data. It is under View-> Toolbar-> Report Toolbar.

    If you canu2019t see the sort button option, enable the right to sort the data under Business Objects Enterprise Applications-> WEB Intelligence-> User-> Interactive Reporting: Create and Edit Sort.

    In Order to get data sorted you have to change the objects definition in universe.

    1) Object Properties-> Properties tab-> Edit-> apply sorting option ( Ascending / Descending) then you can see the Lovu2019s Sorted by clicking on Display.

    2) Check the Option "Automatic Refresh Before Use" under Associate List of values Check box.

    All the LOVu2019s generated will be in sorted order.

    I hope this Helpsu2026.

    Thanksu2026

    Pratik

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 17, 2009 at 12:40 PM

    Hi Kelly,

    As I mentioned in my post, If you are using Interactive Viewer you can sort the Data.

    To Use interactive view you have to change the view format of your report using Infoview preferences.

    Follow the below mentioned Steps:

    1. Open the Business Objects Enterprise Java Infoview.

    2. at the top right hand side there you will find 3 buttons, click extreme left button u201C Preferencesu201D below User Name.

    3. Click Web intelligence Document tab and change the View format to Interactive.

    4. Now open the report by clicking on it in View mode it will open in interactive mode.

    Please follow the Steps I mentioned in my post for other queries I mentioned all in detail.

    I Hope this Helpsu2026.

    Thanksu2026.

    Pratik

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pratik,

      Thank you very much for the answer this has lead me to find other things that are going to be useful to me,

      However I have one slight problem. I have set up prompt for team leaders to enter dates and an agents username. It is the prompt of the username that is not in order on the view mode, however it is in order in the modify mode...is there a way around this.

      Just to add as well....in the modify mode it allows me to click the bar just above the first agent name to sort the names into order, however in the view mode it hasnt got that bar as an option which leaves my agent names in the wrong order.

      If anyone else has the answer too please post it.

      Thanks very much all.

      Kelly

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.