Skip to Content
author's profile photo Former Member
Former Member

Save Password in Logon shortcut

Dear Experts,

I am trying to create a logon shortcut but the password field getting disabled while other like user code is accepting entry. How can I save password in this field?

As It is required to pass one of our machine parameter to SAP by auto logon.

Any help will be appreciable.


Rajiv singh.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Feb 15, 2009 at 08:04 AM


    To make the password field available you must change the registry key...

    "EnablePassword"="1" it must be String Value

    Hope will solve out your problem,

    And one thing more it place the password in the text file in Encrypted Form not Native Language so you can't write it


    Just when you find this Password field available write your password there and it will automatically save and not require for next time login.

    Please Reply if not Clear,

    Kind Regards,


    Edited by: Faisal Altaf on Feb 15, 2009 1:53 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 15, 2009 at 05:54 AM

    Open the shortcut created in notepad,

    in user saction, you can find something find like and change entry for password.



    password=xyz "<<<<<<<<<


    and check

    PS : Please note that by doing this you are opening your password public

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      see this sap help.

      Security Measures When Using SAP Shortcuts



      check these blog.

      see the comments after the blog, save password option is discussed there.

      Quote from this sap help

      Logon information

      § Client field u2013 enter your client number. If you cannot remember your client, log on to the system using SAP Logon or SAP Logon Pad.

      § User field u2013 enter your user ID. The field usually already contains your Windows user ID.

      § Password field u2013 If the field has been activated, you can specify a password. It is normally deactivated for security reasons and only your PC administrator can activate this field.

      For security reasons, this is not recommended and a warning appears. You should only include your password in an SAP shortcut if you are certain that no one can access your PC or your disk/folder.


      Edited by: kartik tarla on Feb 15, 2009 12:26 PM

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.