Skip to Content
0
Jun 20, 2018 at 04:09 PM

Issue Update Kernel 7.42 to 7.45 on Iseries

172 Views Last edit Jul 03, 2018 at 07:38 PM 3 rev

I have been trying to upgrade my kernel from 7.42 to 7.45. I have followed both

https://blogs.sap.com/2014/08/09/performing-sap-kernel-upgrade-on-ibm-i-using-apysidkrn-command/ and sap note 1097751. I have downloaded

When I run APYSIDKRN SID(DV2) ARCHIVES('kernel_745U/*') SAVSAR(*NONE) MODE(*TEST) CHGENV(*NO) UPDAPAR(*NO) INFOAPAR('/usr/sap/trans/config/infoapar.710')

i get APYSIDKRN: No SAR files found to extract.

Did I download the wrong files? I put them in the folder under rootbin, and I have changed my current directory to be the folder I created above.

Ideas?

Update: added SAP_TOOLS first in liblist and now I can run the command in test mode but getting 12 hints. Do I need to fix/find patchs from them, or will kernel upgrade fix them?

In the current program environment patch ccmagent (in Unicode directory - level 723 or higher) is recommended (your current level is 700). <=== This is Hint 1
In the current program environment patch dw (in Unicode directory - level 723 or higher) is recommended (your current level is 700). <=== This is Hint 2

In the current program environment patch enserver (in Unicode directory – level 722 or higher) is recommended (your current level is 700). <=== This is Hint 3

In the current program environment patch igsexe (level 17 or higher) is recommended (your current level is 8). <=== This is Hint 4

In the current program environment patch librfc (in Unicode directory - level 716 or higher) is recommended (your current level is 700). <=== This is Hint 5

In the current program environment patch R3trans (in Unicode directory - level 718 or higher) is recommended (your current level is 700). <=== This is Hint 6

In the current program environment patch SAPCAR (level 721 or higher) is recommended (your current level is 700). <=== This is Hint 7

Details can be found in the following notes: ,2610156,2636321,2618147,2641075,2637738,2636381,2644047,2644410,643996, 2644611,2647109,2584776,635095

In the current program environment patch saphttp (in Unicode directory - level 719 or higher) is recommended (your current level is 700). <=== This is Hint 8

In the current program environment patch saplicense (in Unicode directory - level 713 or higher) is recommended (your current level is 700). <===This is Hint 9

In the current program environment patch sapmc (in Unicode directory - level 413 or higher) is available as addition. <=== This is Hint 10

In the current program environment patch SAPSLDREG (in Unicode directory level 710 or higher) is recommended (your current level is 700). <=== This is Hint 11

In the current program environment patch tp (in Unicode directory – level 715 or higher) is recommended (your current level is 700). <=== This is Hint 12

Attachments

chsus.png (9.5 kB)