Skip to Content
avatar image
Former Member

Deployment not possible

Hi there,

currently I am facing the problem that I can not deploy a web dynpro application on server.

The deployment process always aborts with error message "SDM port not defined or not found".

Logging on to SDM via the Remote GUI (on server) works fine and in the SAP Management Console the SDM service is running without errors.

So what could have went wrong? And how and where can I check and specify the SDM port?

Thans in advance for all answers!

Best Regards,

Torben

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    Feb 12, 2009 at 01:05 PM

    Hi,

    If you are using NWDS to deploy WD apps then you have to mention SAP j2EE Engine details using the menu Windows->Preferences -> SAP J2EE engine

    Provide Message Server host and Message Server port here and deploy the app

    You can find Message Server Host and port using the link

    http://<host name>:<port>/monitoring/SystemInfo

    Regards,

    Santhosh

    Edited by: Santhosh Edla on Feb 12, 2009 4:06 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 12, 2009 at 01:06 PM

    HI,

    NWDS -> Click on 'Window' in the menu bar-> Preferences ->SAP J2EE engine

    -> Select Remote host

    Enter message server name and port no (e.g. 36xx, 39xx xx is instance no) .

    You can get these details from the basis team check with them.

    You can check the current status in NWDS like this,

    NWDS -> Click on 'Window' in the menu bar->Show View -> Select Other ->Open J2EE node -> Select J2EE engine.

    In this J2EE engine view you can see the status of your server.

    Regards,

    Siva

    Edited by: Siva Rama Krushna on Feb 12, 2009 6:38 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      After doing the above settings also if you are facing the same problem then check the port number in the development Infrastucture perspective. If it -1 then do the following steps.

      (To check the port number in the NWDI Select a Development component in a Software Component and in the component properties under DCLocations you can find the Server name and port number)

      Shutdown the Server and then Shutdown the server machine Start the Server machine and Start the server.

      Check the port number in NWDI.

      Now you try to deploy the application.

      Hope it Helps,

      Regards,

      Gayathri.

  • avatar image
    Former Member
    Feb 12, 2009 at 01:12 PM

    Hi,

    check the below links.

    how-can-i-find-sdm-port-message-server-port-messag

    how-to-set-sdm-port

    Regards

    Narendra

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 12, 2009 at 04:10 PM

    Hi,

    go to...

    windows->prefrences->SAP J2EE Engine->

    1. Message Server host : <provide correct ip address of SDM server>

    2 Message Server port: <provide correct port number of SDM server>

    now switch to Lower-right pane n click on j2ee engine tab..nw refresh it.

    u'll see the dispatcher,server0,SDM running..

    green light will indicate that all 3 are running ..

    if its not working then close NWDS n reopen it...

    Regards

    Khushboo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 13, 2009 at 12:41 AM

    Hi Torben,

    Were you able to deploy before? If this is the first time you are deploying a Webdynpro application then you need to provide J2EE engine in you NWDS. The above posts explains it well.

    If you were able to deploy before and the problem started recently then you can check if there were any new changes to the server. You can check the firewall on the server. You can try disabling the firewall on the server and see if you can deploy from your IDE.

    As you mentioned before since SDM is running on the server, the required ports might be blocked.

    Sanyev

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 13, 2009 at 08:46 AM

    Hello Torben,

    a few weeks ago I got a similar error message while deploying a webdynpro.

    In my case the reason for this exception was that I tried to deploy my webdynpro at a Netweaver 7.0. But I had developed the webdynpro at CE 7.1 and were trying to deploy from there also.

    Obviously it is not possible to deploy a webdynpro from NWDS to a server from an older version. This is not supported.

    So please check if the version of your NWDS is younger than your server where you want to deploy.

    Regards,

    Iris

    Add comment
    10|10000 characters needed characters exceeded